libcurl-devel on Redhat is not a valid package

Bug #527255 reported by Justin Shepherd on 2010-02-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Drizzle
Medium
Monty Taylor
Cherry
Medium
Monty Taylor

Bug Description

This is a documentation error only, not related to build issues:

Tarball: drizzle-2010.02.1304.tgz

Files Involved:
.. configure:33245
.. plugin/auth_http/plugin.ac:8

Error Text: "On RedHat it's in libcurl-devel"

Correct Text: "On Redhat it's in curl-devel"

-----

--- plugin/auth_http/plugin.ac 2010-02-15 13:19:12.000000000 -0500
+++ plugin/auth_http/plugin.ac.PATCH 2010-02-24 13:21:06.000000000 -0500
@@ -5,7 +5,7 @@ AC_LIB_HAVE_LINKFLAGS(curl,,
     handle=curl_easy_init();
   ])
 AS_IF([test "x$ac_cv_libcurl" = "xno"],
- AC_MSG_WARN([libcurl development lib not found: not building auth_http plugin. On Debian this is found in libcurl4-gnutls-dev. On RedHat it's in libcurl-devel.]),[
+ AC_MSG_WARN([libcurl development lib not found: not building auth_http plugin. On Debian this is found in libcurl4-gnutls-dev. On RedHat it's in curl-devel.]),[
   AC_CACHE_CHECK([if libcurl has CURLOPT_USERNAME],
                  [drizzle_cv_curl_have_username],[
      AC_COMPILE_IFELSE([

Related branches

Justin Shepherd (jshepher) wrote :
Justin Shepherd (jshepher) wrote :
BJ Dierkes (derks) wrote :

This report is correct on RHEL 5 currently, however in Fedora 12 (presumably what will be in RHEL6) this is not the case. curl-devel does not exist in Fedora 12, rather libcurl-devel provides "Files needed for building applications with libcurl".

I see the same error on CentOS 5.4

checking for libcurl... no
configure: WARNING: libcurl development lib not found: not building auth_http plugin. On Debian this is found in libcurl4-gnutls-dev. On RedHat it's in libcurl-devel.

$ yum install libcurl-devel
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * epel: mirror.umoss.org
 * base: mirrors.service.softlayer.com
 * updates: mirrors.service.softlayer.com
 * addons: mirrors.service.softlayer.com
 * extras: mirrors.service.softlayer.com
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
No package libcurl-devel available.
Nothing to do
$yum info libcurl
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * epel: mirror.umoss.org
 * base: mirrors.service.softlayer.com
 * updates: mirrors.service.softlayer.com
 * addons: mirrors.service.softlayer.com
 * extras: mirrors.service.softlayer.com
Excluding Packages in global exclude list
Finished
Error: No matching Packages to list
$ yum search libcurl
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * epel: mirror.umoss.org
 * base: mirrors.service.softlayer.com
 * updates: mirrors.service.softlayer.com
 * addons: mirrors.service.softlayer.com
 * extras: mirrors.service.softlayer.com
Excluding Packages in global exclude list
Finished
curl-devel.i386 : Files needed for building applications with libcurl.
python-pycurl.x86_64 : A Python interface to libcurl
openser-xcap_client.x86_64 : XCAP client
perl-WWW-Curl.x86_64 : Perl extension interface for libcurl
curl-devel.x86_64 : Files needed for building applications with libcurl.

Installing curl-devel gives me an expected outcome

checking for libcurl... yes
checking how to link with libcurl... -lcurl
checking if libcurl has CURLOPT_USERNAME... no

Lee Bieber (kalebral) on 2010-04-21
Changed in drizzle:
assignee: nobody → Monty Taylor (mordred)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers