A Lightweight SQL Database for Cloud Infrastructure and Web Applications

configure not checking libpam headers

Reported by iwankgb on 2009-11-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Drizzle
High
Monty Taylor
Cherry
High
Monty Taylor

Bug Description

When compiling drizzle using --with-auth-pam-plugin option configure script does not check if libpam headers are installed. If they're not installed then drizzle is compiled without PAM authentication support.

OS: Ubuntu 9.10
Drizzle version: drizzle-2009.11.1208
libpam version: 1.1.0-2ubuntu1
configure options: --prefix=/home/maciek/opt/drizzle --with-libprotobuf-prefix=/home/maciek --with-libdrizzle-prefix=/home/maciek --with-auth-pam-plugin

iwankgb (kasztelix) wrote :

Also: if you compile drizzle without --with-auth-pam-plugin but libpam headers are installed then drizzle will be compiled with PAM support.

Lee Bieber (kalebral) on 2009-11-20
Changed in drizzle:
status: New → Confirmed
milestone: none → bell
assignee: nobody → Monty Taylor (mordred)
importance: Undecided → High
Lee Bieber (kalebral) on 2010-01-26
Changed in drizzle:
status: Confirmed → Fix Committed
Lee Bieber (kalebral) on 2010-01-29
Changed in drizzle:
milestone: bell → cherry
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers