variables test fails as of build 1144 on linux 32 bit machines

Bug #438852 reported by Lee Bieber on 2009-09-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Drizzle
Critical
fmpwizard

Bug Description

Failure seen on debian and ubuntu 32 bit machines

http://gorf.tangent.org/hudson/job/drizzle-norbye.org-32bit-build/67/console
http://solace.inaugust.com/builders/ubuntu904.32.1/builds/90/steps/test/logs/stdio

main.variables [ fail ] --- ../tests/r/variables.result 2009-09-29 03:29:08.000000000 +0300
+++ ../tests/r/variables.reject 2009-09-29 09:31:21.000000000 +0300
 -544,14 +544,20 @@
 set @@global.error_count=1;
 ERROR HY000: Variable 'error_count' is a read only variable
 set @@max_heap_table_size= 4294967296;
+Warnings:
+Error 1292 Truncated incorrect max_heap_table_size value: '4294967296'
 select @@max_heap_table_size > 0;
 @@max_heap_table_size > 0
 1
 set global max_heap_table_size= 4294967296;
+Warnings:
+Error 1292 Truncated incorrect max_heap_table_size value: '4294967296'
 select @@max_heap_table_size > 0;
 @@max_heap_table_size > 0
 1
 set @@max_heap_table_size= 4294967296;
+Warnings:
+Error 1292 Truncated incorrect max_heap_table_size value: '4294967296'
 select @@max_heap_table_size > 0;
 @@max_heap_table_size > 0
 1

drizzletest: Result content mismatch

Related branches

Lee Bieber (kalebral) on 2009-09-29
Changed in drizzle:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → bell
assignee: nobody → Brian Aker (brianaker)
Lee Bieber (kalebral) on 2009-09-29
Changed in drizzle:
assignee: Brian Aker (brianaker) → fmpwizard (diego-fmpwizard)
Changed in drizzle:
status: Confirmed → Fix Committed
status: Fix Committed → In Progress
fmpwizard (diego-fmpwizard) wrote :

revno: 1137
committer: Diego Medina <email address hidden>
branch nick: bug-fixes
timestamp: Tue 2009-09-29 14:50:44 -0400
message:
  * Fixes bug#438852
  ** variables test fails as of build 1144 on linux 32 bit machines
  ** Some linux systems use i686 to indicate they are 32-bit

Changed in drizzle:
status: In Progress → Fix Committed
Lee Bieber (kalebral) on 2009-10-06
Changed in drizzle:
status: Fix Committed → Fix Released
Josh Koenig (joshkoenig) wrote :

Seems related, though I'm not sure as the initial links to the consoles are 404ing for me.

Anyway, running a fresh bzr merge as of today (10/11) my make falls down as follows on a 32 bit Ubuntu 9.04 (jaunty) machine:

libtool: link: ranlib plugin/.libs/libheap_plugin.a
libtool: link: rm -fr plugin/.libs/libheap_plugin.lax
libtool: link: ( cd "plugin/.libs" && rm -f "libheap_plugin.la" && ln -s "../libheap_plugin.la" "libheap_plugin.la" )
depbase=`echo client/drizzle.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`;\
        g++ -DHAVE_CONFIG_H -I. -I. -ggdb3 -pthread -pipe -O3 -Werror -pedantic -Wall -Wextra -Wundef -Wshadow -fdiagnostics-show-option -fvisibility=hidden -Wformat -fno-strict-aliasing -Wno-strict-aliasing -Woverloaded-virtual -Wnon-virtual-dtor -Wctor-dtor-privacy -Wno-long-long -Wmissing-declarations -Wno-redundant-decls -Wno-attributes -std=gnu++0x -MT client/drizzle.o -MD -MP -MF $depbase.Tpo -c -o client/drizzle.o client/drizzle.cc &&\
        mv -f $depbase.Tpo $depbase.Po
client/drizzle.cc: In function ‘int drizzleclient_real_query_for_lazy(const char*, int, drizzle_result_st*, uint32_t*)’:
client/drizzle.cc:2649: error: ‘DRIZZLE_RETURN_SERVER_GONE’ was not declared in this scope
client/drizzle.cc: In function ‘const char* fieldtype2str(drizzle_column_type_t)’:
client/drizzle.cc:2963: error: ‘DRIZZLE_COLUMN_TYPE_VIRTUAL’ was not declared in this scope
client/drizzle.cc: In function ‘int com_use(std::string*, const char*)’:
client/drizzle.cc:3819: error: ‘DRIZZLE_RETURN_SERVER_GONE’ was not declared in this scope
make[2]: *** [client/drizzle.o] Error 1
make[2]: Leaving directory `/root/drizzle'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/drizzle'
make: *** [all] Error 2

Lee Bieber (kalebral) wrote :

Looks like you are using the very latest libdrizzle which is not quite ready for primetime. Try an earlier version of libdrizzle for now until we sort out compatibility issues between libdrizzle and drizzle.

Josh Koenig (joshkoenig) wrote :

Yep. Same thing happened on my 64-bit box. Will grab 0.4 of libdrizzle and rock it from there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers