broken build against drizzle PPA

Bug #742823 reported by SapphirePaw on 2011-03-25
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Drizzle PHP Extension
Medium
Unassigned

Bug Description

System: Ubuntu Maverick Desktop as a VirtualBox guest, Drizzle PPA.

After running phpize, ./configure ends with the message:

checking whether to enable drizzle support... yes, shared
not found
configure: error: Please install libdrizzle

config.log has at the corresponding location:

configure:3975: checking whether to enable drizzle support
configure:4018: result: yes, shared
configure:4036: result: not found
configure:4038: error: Please install libdrizzle

I think configure is expecting to find /usr/include/libdrizzle/drizzle.h, but libdrizzle-dev 2011.03.13-0ubuntu1~maverick0 has installed /usr/include/libdrizzle-1.0/libdrizzle/drizzle.h instead--libdrizzle-1.0 has been added to the path.

drizzle-php-ext from bzr; drizzle/libdrizzle/*-dev from drizzle PPA ( deb http://ppa.launchpad.net/drizzle-developers/ppa/ubuntu maverick main )

pscott (pscott) wrote :

Same issue experienced on Natty too. libdrizzle installs to /usr/include/libdrizzle-1.0/libdrizzle/drizzle.h but when running the configure script the --with-drizzle= option does not allow you to properly specify the drizzle path and still fails.

This is confirmed by the fact that the configure script will complete when modifying line 1407 (after phpize) to:

if test -r $i/include/libdrizzle-1.0/libdrizzle/drizzle.h; then

on the drizzle-php-ext-0.5 download (.tar.gz)

the configure script will complete but make will fail with

drizzle-php-ext-0.5/php_drizzle.c:26:39: fatal error: libdrizzle/drizzle_client.h: No such file or directory
compilation terminated.
make: *** [php_drizzle.lo] Error 1

Changed in drizzle-php-ext:
status: New → Confirmed
importance: Undecided → Medium
Gopal Venkatesan (gopal418) wrote :

I have worked around this temporarily (I know its not the right way to do it though):

--- patch to configure ---

--- configure.orig 2011-07-19 11:07:04.000000000 -0400
+++ configure 2011-07-19 11:07:46.000000000 -0400
@@ -3419,9 +3419,9 @@

 if test "$PHP_DRIZZLE" != "no"; then
   for i in $PHP_DRIZZLE /usr/local /usr /opt/local; do
- if test -r $i/include/libdrizzle/drizzle.h; then
+ if test -r $i/include/libdrizzle-1.0/libdrizzle/drizzle.h; then
       DRIZZLE_LIB_DIR=$i/lib
- DRIZZLE_INC_DIR=$i/include
+ DRIZZLE_INC_DIR=$i/include/libdrizzle-1.0
       echo "$as_me:$LINENO: result: found in $i" >&5
 echo "${ECHO_T}found in $i" >&6
       break

Gopal Venkatesan (gopal418) wrote :

I'm sorry the above patch was for 0.4.1, for the latest version here's the patch:

--- configure.orig 2011-08-07 20:37:55.603002702 +0000
+++ configure 2011-08-07 20:38:27.551914048 +0000
@@ -4490,9 +4490,9 @@

 if test "$PHP_DRIZZLE" != "no"; then
   for i in $PHP_DRIZZLE /usr/local /usr /opt/local; do
- if test -r $i/include/libdrizzle/drizzle.h; then
+ if test -r $i/include/libdrizzle-1.0/libdrizzle/drizzle.h; then
       DRIZZLE_LIB_DIR=$i/lib
- DRIZZLE_INC_DIR=$i/include
+ DRIZZLE_INC_DIR=$i/include/libdrizzle-1.0
       { $as_echo "$as_me:$LINENO: result: found in $i" >&5
 $as_echo "found in $i" >&6; }
       break

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers