Add all the sketches to the image for testing

Bug #1763677 reported by Benoît St-Jean on 2018-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dr. Geo II
Wishlist
Benoît St-Jean

Bug Description

It would be useful to add all the scripts/sketches (located at https://bazaar.launchpad.net/~drgeo-developers/drgeo/trunk/files/head:/build/SmalltalkSketches/) to the image so we could run them into SUnit to detect regressions and/or use them to profile Dr. Geo.

This is not a bug but a "nice to have" feature.

Benoît St-Jean (bstjean) wrote :

I started adding all the sketches to the image. Will provide a fileOut of all classes soon. And will create a TestCase for every one of them as well.

Changed in drgeo:
status: New → In Progress
assignee: nobody → Benoît St-Jean (bstjean)
Benoît St-Jean (bstjean) wrote :

First version of the sketches. Will do some minor cleanup in the scripts (for instance, always naming the canvas with the name "canvas" instead of "fig", "c", "sketch" or something else.

Will add test cases for each one later.

Changed in drgeo:
importance: Undecided → Wishlist
Changed in drgeo:
milestone: none → 18.06
hilaire (hilaire-fernandes) wrote :

Yep, using the Smalltalk sketches as the base for additional testings is a great idea. Indeed, in the past the scripts helped to discover additional bugs.

What about to have test cases where the resources are scripts load from the file repository, then the test case just asserts it runs without error?

That way, when one script is modified or added, a whole DrGeoII-Sketches package doesn't need to be updated (or needed by the way).

What do you think about it?

Yes, that would be way simpler!!

I was thinking about returning the canvas at the end of each script with "^canvas" but after further thinking, all we need to do is trap any error with an exception handler!

-----------------
Benoît St-Jean
Yahoo! Messenger: bstjean
Twitter: @BenLeChialeux
Pinterest: benoitstjean
Instagram: Chef_Benito
IRC: lamneth
Blogue: endormitoire.wordpress.com
"A standpoint is an intellectual horizon of radius zero".  (A. Einstein)

    On Friday, April 20, 2018, 3:31:08 a.m. EDT, hilaire <email address hidden> wrote:

 Yep, using the Smalltalk sketches as the base for additional testings is
a great idea. Indeed, in the past the scripts helped to discover
additional bugs.

What about to have test cases where the resources are scripts load from
the file repository, then the test case just asserts it runs without
error?

That way, when one script is modified or added, a whole DrGeoII-Sketches
package doesn't need to be updated (or needed by the way).

What do you think about it?

--
You received this bug notification because you are subscribed to the bug
report.
Matching subscriptions: Dr. Geo bug report
https://bugs.launchpad.net/bugs/1763677

Title:
  Add all the sketches to the image for testing

Status in Dr. Geo II:
  In Progress

Bug description:
  It would be useful to add all the scripts/sketches (located at
  https://bazaar.launchpad.net/~drgeo-
  developers/drgeo/trunk/files/head:/build/SmalltalkSketches/) to the
  image so we could run them into SUnit to detect regressions and/or use
  them to profile Dr. Geo.

  This is not a bug but a "nice to have" feature.

To manage notifications about this bug go to:
https://bugs.launchpad.net/drgeo/+bug/1763677/+subscriptions

tags: added: script test
removed: have nice to wishlist
tags: added: smalltalk-sketch
removed: script
hilaire (hilaire-fernandes) wrote :

Added a DrGeoScriptTest class to test individually each Smalltalk sketch files

Changed in drgeo:
status: In Progress → Fix Committed
Changed in drgeo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers