With Dark graphic theme, label are printed in white on white

Bug #1699162 reported by hilaire on 2017-06-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dr. Geo II
Medium
Unassigned

Bug Description

The label should be forced to black, as the canvas background itself is always painted in white.

Alternatively, adapt the canvas background to the graphic theme.

Benoît St-Jean (bstjean) wrote :

Which labels? Do you have a step by step example with a screenshot?

The dark theme label seems to be just fine now with P7. May be we can
make DrGeo using the Dark theme by default for next release. And the
canvas background could be adjust to be darker too, as shown in the
attachment.

Le 22/04/2018 à 19:26, Benoît St-Jean a écrit :
> Which labels? Do you have a step by step example with a screenshot?

--
GNU Dr. Geo
http://drgeo.eu

hilaire (hilaire-fernandes) wrote :

What happens is Dark theme sets default text color to white, so the label representing the name of the point, line will be white on a white canvas, so not visible.
To see this happens, you need to edit the style of an object and name it (by default Dr. Geo does not put name on objects).

However as wrote earlier, under the Dark theme the canvas should not be white but more like a paler grey, it will be more comfortable for the eyes.

hilaire (hilaire-fernandes) wrote :

Additional note: using the Dark theme requires some caution when exporting a sketch to a bitmap. Indeed in that case you may still want to have white background and black label, particularly when you want to import the exported bitmap in a word processing document.

Benoît St-Jean (bstjean) wrote :

This looks VERY nice indeed!

En plus, c'est moins fatiguant pour les yeux que le fond blanc (mon opinion).  Quoique ça pourrait aussi être une préférence mais le défaut serait le "dark Theme"

-----------------
Benoît St-Jean
Yahoo! Messenger: bstjean
Twitter: @BenLeChialeux
Pinterest: benoitstjean
Instagram: Chef_Benito
IRC: lamneth
Blogue: endormitoire.wordpress.com
"A standpoint is an intellectual horizon of radius zero".  (A. Einstein)

    On Monday, April 23, 2018, 4:26:16 p.m. EDT, hilaire <email address hidden> wrote:

 The dark theme label seems to be just fine now with P7. May be we can
make DrGeo using the Dark theme by default for next release. And the
canvas background could be adjust to be darker too, as shown in the
attachment.

Le 22/04/2018 à 19:26, Benoît St-Jean a écrit :
> Which labels?  Do you have a step by step example with a screenshot?

--
GNU Dr. Geo
http://drgeo.eu

** Attachment added: "DrGeoDarkTheme.png"
  https://bugs.launchpad.net/bugs/1699162/+attachment/5126073/+files/DrGeoDarkTheme.png

--
You received this bug notification because you are a member of DrGeo
developers, which is subscribed to Dr. Geo II.
Matching subscriptions: Dr. Geo bug report
https://bugs.launchpad.net/bugs/1699162

Title:
  With Dark graphic theme, label are printed in white on white

Status in Dr. Geo II:
  New

Bug description:
  The label should be forced to black, as the canvas background itself
  is always painted in white.

  Alternatively, adapt the canvas background to the graphic theme.

To manage notifications about this bug go to:
https://bugs.launchpad.net/drgeo/+bug/1699162/+subscriptions

Changed in drgeo:
status: New → Confirmed
status: Confirmed → In Progress
Changed in drgeo:
status: In Progress → Fix Committed
Changed in drgeo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers