cannot open the attached .fgeo file

Bug #1539835 reported by Chao-Kuei Hung on 2016-01-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dr. Geo II
High
hilaire

Bug Description

When opening the attached err.fgeo file, DrGeo emits this message repeatedly (maybe infinitely). The only way out is to close pharo. (Even closing the sketch does not help.) Also attached is an earlier version of the sketch that works fine.

DrGeo 15.12a running on lubuntu 15.04 x86_64.

Chao-Kuei Hung (ckhung0) wrote :
Chao-Kuei Hung (ckhung0) wrote :

sorry, ok.fgeo is NOT its earlier version. I lost my earlier version of this sketch.

The ok.fgeo file opens ok.
The err.fgeo file opens with the error you described.

I pass over the error at opening but the resulting sketch is pretty
inconsistent. Only axes are displayed and some point and a gravity drag.
Dragging point is also very slow on this sketch.

You may have hit a serious bug.
Do you have an idea what changes in your sketch lead to this error?

Le 30/01/2016 05:34, Chao-Kuei Hung a écrit :
> Public bug reported:
>
> When opening the attached err.fgeo file, DrGeo emits this message
> repeatedly (maybe infinitely). The only way out is to close pharo. (Even
> closing the sketch does not help.) Also attached is an earlier version
> of the sketch that works fine.
>
> DrGeo 15.12a running on lubuntu 15.04 x86_64.
>
> ** Affects: drgeo
> Importance: Undecided
> Status: New
>
>
> ** Tags: fatal file
>
> ** Attachment added: "err.png err.fgeo ok.fgeo"
> https://bugs.launchpad.net/bugs/1539835/+attachment/4559520/+files/undefinedObject.tgz
>

Changed in drgeo:
status: New → Confirmed
importance: Undecided → High
milestone: none → 16.03
tags: added: core
removed: fatal
Changed in drgeo:
status: Confirmed → In Progress
assignee: nobody → hilaire (hilaire-fernandes)
Chao-Kuei Hung (ckhung0) wrote :

ok I am re-doing everything and try to make frequent saves so as to make comparison and debuggin easier.

I saw a few small glitches before. For example, the parabola is not drawn completely. But I didn't pay much attention. From now on I will pay attention to strange details and report back.

hilaire (hilaire-fernandes) wrote :

I can produce the construction you described without problem, but I am working with a development version and I think the bug your are exposed to is https://bugs.launchpad.net/bugs/1529133

I just upload a rolling release configuration of DrGeo with 16.03 bug fixes.

From your 15.12 Dr. Geo, you can make very easily an update.
See screenshot how to do it: http://forum.drgeo.eu/attachment/2770746/0/drgeo-update.png

Please, can you confirm the bug is gone after this update.

Chao-Kuei Hung (ckhung0) wrote :

Yes, this bug is gone after I upgraded to 16-03a!

Changed in drgeo:
status: In Progress → Fix Committed
Changed in drgeo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers