DrGLabelMorph fail for Pharo3

Bug #1411097 reported by HwaJong Oh on 2015-01-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dr. Geo II
High
Unassigned

Bug Description

operating system: Mac OS X 10.10

Dr. Geo version: I don't know but I installed with

Gofer new
   url: 'http://smalltalkhub.com/mc/HilaireFernandes/DrGeo/main';
   package: 'ConfigurationOfDrGeo';
   load.
((Smalltalk at: #ConfigurationOfDrGeo) project version: #stable) load.

It requires #getPreciseAscent method, which can be found in the Athens package. I think this problem can be fixed by changing metacello config to load Athens while loading DrGeoII.

HwaJong Oh (hwajongoh) wrote :
hilaire (hilaire-fernandes) wrote :

By default, Pharo 3 use bitmap which is not compatible with Athens.
Before running DrGeo you need to activate FreeType and use true type font for the whole system (to do from the Settings browser)

The set up is described from the Dr. Geo's SmalltalkHub page:
http://smalltalkhub.com/#!/~HilaireFernandes/DrGeo

Changed in drgeo:
status: New → Triaged
hilaire (hilaire-fernandes) wrote :

Loading Athens is not necessary, it is already present in Pharo3.

Or, did you find in your investigation, that newer version of Athens support Bitmap font (aka StrikeFont, as one can read in your screen shot)?

I ve concluded that Athens is needed because image of loading DrGeo2 with metacello on frresh Pharo3 does not have #getPreciseAscent. but it is defined in image of loading Athens.

HwaJong

2015. 1. 17. 오후 6:46 Hilaire Fernandes <email address hidden> 작성:

> Loading Athens is not necessary, it is already present in Pharo3.
>
> Or, did you find in your investigation, that newer version of Athens
> support Bitmap font (aka StrikeFont, as one can read in your screen
> shot)?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1411097
>
> Title:
> DrGLabelMorph fail for Pharo3
>
> Status in Dr. Geo II:
> Triaged
>
> Bug description:
> operating system: Mac OS X 10.10
>
> Dr. Geo version: I don't know but I installed with
>
> Gofer new
> url: 'http://smalltalkhub.com/mc/HilaireFernandes/DrGeo/main';
> package: 'ConfigurationOfDrGeo';
> load.
> ((Smalltalk at: #ConfigurationOfDrGeo) project version: #stable) load.
>
>
> It requires #getPreciseAscent method, which can be found in the Athens package. I think this problem can be fixed by changing metacello config to load Athens while loading DrGeoII.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/drgeo/+bug/1411097/+subscriptions

HwaJong Oh (hwajongoh) wrote :

You are right! Loading Athens is not necessary.
But, this problem is solved by turning off&on the "Use Free type font" option in the System settings.
I hope this manual setting change automated into some initialization code.

hilaire (hilaire-fernandes) wrote :

Le 04/02/2015 16:26, HwaJong Oh a écrit :
> You are right! Loading Athens is not necessary.
> But, this problem is solved by turning off&on the "Use Free type font" option in the System settings.
> I hope this manual setting change automated into some initialization code.
>

You may want to have a look at the DrGeo install class for the correct
initialization code -- used in the process to build the Dr.Geo.app
bundle. This code is not part of the ConfigurationOfDrGeo initialization
process thought.

Hilaire

HwaJong Oh (hwajongoh) wrote :

I've found code related font initialization in DrGeoInstaller

"FreeTypeFontProvider unload."

which seem not enough for me.

How about changing it to something like...

fontFamilyName := 'Arial'.

FreeTypeSystemSettings loadFt2Library: true.
FreeTypeFontProvider current updateFromSystem.

font := [:fontSize| LogicalFont
                         familyName: fontFamilyName
                         pointSize: fontSize].

StandardFonts defaultFont: (font value: 9).
StandardFonts codeFont: (font value: 9).
StandardFonts listFont: (font value: 9).
StandardFonts menuFont: (font value: 9).
StandardFonts buttonFont: (font value: 9).
StandardFonts windowTitleFont: (font value: 12).
StandardFonts balloonFont: (font value: 7).
StandardFonts haloFont: (font value: 7).

hilaire (hilaire-fernandes) wrote :

Le 15/02/2015 11:00, HwaJong Oh a écrit :
> I've found code related font initialization in DrGeoInstaller
>
> "FreeTypeFontProvider unload."

Hi,

I am sorry I misguided you a bit, I forgot a bit about the way it is set
up in DrGeo, as I coded it several years ago...

In fact, in the DrGeo bundle, Font installation is done at every DrGeo
startup. It is because depending on the locale (language) where DrGeo is
used, a different font is used. DrGeo bunde comes with two fonts, one
for Korean and second one for the other languages.
All this magic is done from the DrGDefault startup sequence.

But your proposal is not lost, I added it in the DrGeo description page at
    http://smalltalkhub.com/#!/~HilaireFernandes/DrGeo
and it is definitely a useful addition.

Hope it is an acceptable solution for you.

Thanks

Hilaire

Changed in drgeo:
importance: Undecided → High
milestone: none → wip
Changed in drgeo:
status: Triaged → In Progress
Changed in drgeo:
milestone: wip → 15.04
status: In Progress → Confirmed
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments