edit macro description afterwards

Bug #1018281 reported by Chao-Kuei Hung on 2012-06-27

This bug report was converted into a question: question #205298: edit macro description afterwards.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dr. Geo II
Wishlist
hilaire

Bug Description

Can we have an "edit macro description" functionality so that the user can change a macro's description after it is constructed?

hilaire (hilaire-fernandes) wrote :

As it is right now, description can be saved with a Alt-s in the description text area. However there is a text conversion problem when saving the macro. It is fixed now.

Changed in drgeo:
importance: Undecided → Medium
assignee: nobody → Hilaire Fernandes (hilaire-fernandes)
milestone: none → 12.07
status: New → Fix Committed
Chao-Kuei Hung (ckhung0) wrote :

I am not sure I follow you... When you say "description can be saved with a Alt-s in the description text area" do you mean that one can do this ##while one is creating the macro##? What I would like to have is: one constucts a macro, then uses other tools to create other points and lines, then ##some hours or days later## changes his mind and ##somehow## goes back to edit the macro description that was already saved during the macro construction.

This ##somewho## could be either
- add a submenu "edit macro description" to go along with "build macro", "execute macro", "delete macro", or
- add a visible object as a representation of an abstract macro construction, then let user "Edit an item's property".
Or is there an existing way to do this ##somehow## where one can type Alt-s ?

Le 13/07/2012 10:05, Chao-Kuei Hung a écrit :
> I am not sure I follow you... When you say "description can be saved
> with a Alt-s in the description text area" do you mean that one can do
> this ##while one is creating the macro##? What I would like to have is:

No, it is while one is using an existing macro, it can edit its
description and save it with Alt-s.
An option will be additional save description button or reminder in a
tooltips.

Thanks

Hilaire

> one constucts a macro, then uses other tools to create other points and
> lines, then ##some hours or days later## changes his mind and
> ##somehow## goes back to edit the macro description that was already
> saved during the macro construction.
>
> This ##somewho## could be either
> - add a submenu "edit macro description" to go along with "build macro", "execute macro", "delete macro", or
> - add a visible object as a representation of an abstract macro construction, then let user "Edit an item's property".
> Or is there an existing way to do this ##somehow## where one can type Alt-s ?
>

Changed in drgeo:
status: Fix Committed → Incomplete
milestone: 12.07 → 12.10
Changed in drgeo:
status: Incomplete → Invalid
Chao-Kuei Hung (ckhung0) wrote :

I see. Thanks!

Then, can you please change "Execute Macro" to "Execute Macro or edit its description"?
Also it would help if there is a short description such as "press alt-s to save new description" while one is looking at a macro.

I tried it today. The text change works fine. But the macro seems broken after the text change --
it produces nothing after I select all input items.
It's difficult to describe. I will report back if I figure out the precise steps to reproduce the bug.

Changed in drgeo:
status: Invalid → Confirmed
Changed in drgeo:
milestone: 12.10 → 16.03
Changed in drgeo:
importance: Medium → Wishlist
tags: added: macro user-interface
removed: feature-request
hilaire (hilaire-fernandes) wrote :

I did not notice the problem of unworking macro after changing its description.
I noted other problem related to unicity of items (hash collision problem), it is hopefully fixed now.

I will look at improving the UI to edit its description.

hilaire (hilaire-fernandes) wrote :

Applied a minimal cosmetic UI change (the whole DrGeo UI may change in a so distant future):

- Button renamed to Play/edit macro
- tooltips: 'Execute a pre-built macro-construction on selected input items. To edit a macro description, edit its text and apply with the keys [alt/ctrl]+s.'

Changed in drgeo:
status: Confirmed → Fix Committed
status: Fix Committed → In Progress
hilaire (hilaire-fernandes) wrote :

Can you re-confirm about the macro not working after editing its description?
I can't reproduce the case.

Changed in drgeo:
status: In Progress → Fix Committed
Changed in drgeo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions