Error if docstring contains a null byte

Bug #611513 reported by Vosper on 2010-07-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DreamPie
Undecided
Unassigned

Bug Description

I was in the middle of typing a simple one-line command when a error dialog popped up. I'm not sure if it's relevant, but I have just installed Python 2.7, though DreamPie says it is still using 2.6.4, and all my path variables point to 2.6

I've attached a screenshot of my DreamPie session, as it's very short and fits entirely in the image.

Lastly, thanks for your work on DreamPie, it rocks!

The traceback info is as follows:

Variables:
  File "dreampielib\gui\call_tips.pyc", line 92, show(self=<dreampi...02B936F0>, is_auto=True)
  File "dreampielib\gui\call_tip_window.pyc", line 246, show(self=<dreampi...02BF3C10>, text=u'MZ\uff...\x00\x00', x=146, y=884)

Traceback (most recent call last):
  File "dreampielib\gui\call_tips.pyc", line 92, in show
  File "dreampielib\gui\call_tip_window.pyc", line 246, in show
TypeError: Gtk.Widget.create_pango_layout() argument 1 must be string without null bytes, not unicode

Vosper (craig-glennie) wrote :
Noam Yorav-Raphael (noamraph) wrote :

What is the lxml module? Can you attach it?

By the way, about Python 2.7: You need to create a new DreamPie shortcut to use Python 2.7. If you have DreamPie 1.1, there should be a "add interpreter" command to do it for you.

Thanks for the report and for the nice words,
Noam

Changed in dreampie:
status: New → Incomplete
Noam Yorav-Raphael (noamraph) wrote :

The problem is that the docstring contains a null byte. To reproduce:

def f():
    pass
f.__doc__ = 'a\0b'

f(

(when trying to show the call tip, we get this error.)

summary: - GTK error occurred in middle of typing
+ Error if docstring contains a null byte
Changed in dreampie:
status: Incomplete → Confirmed
Noam Yorav-Raphael (noamraph) wrote :

Fixed in revision 191.

Changed in dreampie:
status: Confirmed → Fix Committed
Changed in dreampie:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers