traceroute packet delay

Bug #1521629 reported by Yuli on 2015-12-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DragonFlow
Low
Unassigned

Bug Description

Hello

When running a traceroute command from a VM occasionally packets get delayed when reaching the control node/network node.
This delay appears every second time I run the traceroute command. Not only for the first try.

Take a look at the attached screenshot.

How to reproduce.
1. Install latest devstack 1 server installation.
2. Install tiny cirros VM.
3. Run the following command several time from the shell:
     traceroute gogle.com

Every couple of time you will run traceroute command, you will see asterix when reaching controller node.
"If an asterisk (*) appears for RTT, then a packet was not returned within the expected timeframe."

Best regards,
Yuli

Yuli (stremovsky) wrote :
Li Ma (nick-ma-z) wrote :

Could you provide the devstack configuration? like centralized df or distributed df?

Li Ma (nick-ma-z) wrote :

Could you compare with other neutron plugin, like openvswitch, in your environment? You ping to google not external net gateway, so this phenomenon is complicated to analyze, because it also relates with public network environment.

I use my single-vm deployment to ping external gateway from an instance, but I cannot reproduce your results.

Changed in dragonflow:
importance: Undecided → Wishlist
Omer Anson (omer-anson) on 2017-09-03
Changed in dragonflow:
importance: Wishlist → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers