Daemon doesn't run due to SQLite issue

Bug #732948 reported by Jonathan J Simon on 2011-03-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Downpour
High
Jeremy Jongsma

Bug Description

When I run downpourd with any set of switches, it doesn't execute properly. I've included a debug trace in a text file. It is also of note that when I install storm through easy_install or pip, compilation fails. I got it installed through apt. I'm not sure if that would cause this error.

I'm running an Ubuntu 10.10 amd64 machine. I have root permissions. Other python based daemons are running, so I doubt it's my python setup.

On a somewhat unrelated note, /etc/downpour.cfg doesn't seem to be present, and your site doesn't provide syntax for what that file should look like.

Kyle Brown (shopeonarope) wrote :

I am getting the exact same debug output as the above mentioned, though my setup is just the same, 10.10 amd64. I did however get it to install successfully via easy_install.
There is a default downpour.cfg in the tarfile in cfg/downpour.cfg ( I had a hard time with that too)

Kento (kenny-nilssonsjalv) wrote :

Have you guys created the folder where the database is located?
If you havnt touched your cfg it should be /var/lib/downpour

Kyle Brown (shopeonarope) wrote :

Thanks for the tip, I had to create /var/lib/downpour/tmp and /var/lib/downpour/downloads and it worked great!! Those folders are specified in downpour.cfg so you can make them where ever you'd like.

Kyle - good call.

siguy (simon-snow) wrote :

I've created these folders and I am still having the same issue. I've created the user downpour and set the owner/group of the folders to downpour/downpour so there should be no problem writing files there. I have also tried starting downpour as root and I get the exact same error. I attached my debug trace.

Jeremy Jongsma (jeremy-jongsma) wrote :

Make sure that your state database, work_directory and user_directory paths are accessible to the downpour user. I have added that to the installation instructions - these are things that should be done automatically once it is packaged properly.

siguy, please post the contents of your downpour.cfg. If you haven't created a config file and specified a database location, it defaults to creating the database in ~/.config/downpour/downpour.db, which is probably where it's failing. I just committed a fix to SVN to auto-create that directory if it is missing.

It also seems the 0.2 package does not include a default configuration file. You can grab one from here:

http://home.jongsma.org/svn/downpour/trunk/cfg/downpour.cfg

Downpour looks for the config file in the following locations: /etc/downpour.cfg, then ~/.config/downpour/downpour.cfg.

Jeremy Jongsma (jeremy-jongsma) wrote :

I should say, the easy_install method does not include a default config file. The source package does.

siguy (simon-snow) wrote :

I did a manual installation as per the instructions, made a copy of the default downpour.cfg in etc and edited that. Here it is:

[downpour]
user=downpour
group=downpour
state=/var/lib/downpour/downpour.db
work_directory=/var/lib/downpour/tmp
user_directory=/var/lib/downpour/downloads
plugins=downpour.remote.RemotePlugin,downpour.web.WebInterfacePlugin

[downpour.remote.RemotePlugin]
interface=localhost
port=6226

[downpour.web.WebInterfacePlugin]
interface=10.0.0.10
port=9090

I have created the downpour, downpour/tmp, downpour/downloads directory in /var/lib and made sure they were owned by the downpour user/group.

Have you gone into the shell as the "downpour" user and tried creating a file manually in /var/lib/downpour?

Do you have any sort of SELinux running?

siguy (simon-snow) wrote :

Yup, logged in as the downpour user and tested writing in all of the applicable folders. That all works just fine.

Not running any unusual kind of linux

Linux servinator 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux
Ubuntu 10.10

I'm not sure what the issue could be then without shell access to investigate. I think the others above have resolved their issues with the help of the comments.

I've committed fixes for the workarounds listed above.

Changed in downpour:
milestone: none → 0.3
assignee: nobody → Jeremy Jongsma (jeremy-jongsma)
importance: Undecided → High
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers