Bison needed for PETSc 3.2 on Oneiric

Bug #890774 reported by Anders Logg
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Dorsal
Fix Released
High
Johannes Ring

Bug Description

It looks like the 'bison' package needs to be added to the list of packages for Ubuntu Oneiric:

TESTING: configureLibrary from PETSc.packages.PTScotch(/home/logg/scratch/fenics/src/petsc-3.2-p5/config/BuildSystem/config/package.py:417)
*******************************************************************************
         UNABLE to CONFIGURE with GIVEN OPTIONS (see configure.log for details):
-------------------------------------------------------------------------------
PTScotch needs bison installed
*******************************************************************************

I haven't yet tested whether installing Bison helps (currently building).

Related branches

Changed in dorsal:
status: New → Confirmed
Johannes Ring (johannr)
Changed in dorsal:
status: Confirmed → Fix Committed
importance: Undecided → High
assignee: nobody → Johannes Ring (johannr)
Revision history for this message
Andre Massing (massing) wrote : Re: [Bug 890774] [NEW] Bison needed for PETSc 3.2 on Oneiric

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 11/15/2011 05:58 PM, Anders Logg wrote:
> Public bug reported:
>
> It looks like the 'bison' package needs to be added to the list of
> packages for Ubuntu Oneiric:
>
> TESTING: configureLibrary from
> PETSc.packages.PTScotch(/home/logg/scratch/fenics/src/petsc-3.2-p5/config/BuildSystem/config/package.py:417)
>
>
*******************************************************************************
> UNABLE to CONFIGURE with GIVEN OPTIONS (see configure.log for
> details):
> -------------------------------------------------------------------------------
>
>
PTScotch needs bison installed
> *******************************************************************************
>
> I haven't yet tested whether installing Bison helps (currently
> building).

I just compiled PETSc via dorsal with bison installed from ubuntu
(oneiric) repos, and it worked out fine.

- --
Andre

>
> ** Affects: dorsal Importance: Undecided Status: New
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJOw4+4AAoJEA79ggnbq9dmuhQIAJcvuCUKSNf/mHywQJQITARA
FpZAgfchDFUM3oy07F65Gc4mbKm0nxqrtzKbEKeIBxy9iNLDXWBFHOQef7aAseRc
/2jStm4i1VsOTWzSYc/Qo+auoo5KICBX2Hzm1fFTmIuQYmButjuEmYt94+5A8RWc
riQr7j0v67o2zZ/ErJh6YUP+CNqzpCAniQfWJet8jhQHziCVR208UBsh81oadBES
IkY3FIEgpHuoptCdA+FQAMpnDJfrA91zMkLMrHAqj5HyKpPTN5iM27L7+yWl+ovb
1nUE4zKnOfY1DLKuoPbRfbQIQe6aKPWZzKIRZr/g8Ka2+EfdrHPaJWZQekKSduE=
=SC1O
-----END PGP SIGNATURE-----

Changed in dorsal:
milestone: none → 1.0
Changed in dorsal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers