some fixes needed to build 1.0-beta2 on SL6

Bug #888652 reported by Doug Arnold
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dorsal
Fix Released
Undecided
Harish Narayanan

Bug Description

I just completed building FEniCS 1.0-beta2 using dorsal-1.0-beta2 on both 32 and 64 bit machines running Scientific Linux 6 (which should be pretty identical to RHEL 6). There were a few glitches, which I am reporting. Some of these (e.g., 3) affect other platforms as well.

1. The rhel6.platform file (which dorsal correctly uses) starts with some comments listing packages which should be previously installed. Two more should be added: boost-openmpi and boost-openmpi-devel.

2. Also in the comments of the platform, it says to add ${INSTALL_PATH}/lib/vtk-5.6 to the LD_LIBRARY_PATH. The version 5.6 should be changed to 5.8. Also, on a 64 bit machine /usr/lib64 needs to be added to the LD_LIBRARY_PATH.

3. The SOURCE line in the dolfin-stable.package line need to be updated by replacing "trunk" by "1.0.x".

4. I think it is necessary to manually set

  export BOOST_LIBRARYDIR=/usr/lib/openmpi/lib

or

  export BOOST_LIBRARYDIR=/usr/lib64/openmpi/lib

(according to whether architecture is 32 or 64 bit) before running dorsal.

5. After dorsal completes, the dolfin.conf file needs to be adjusted. The LD_LIBRARY_PATH should be adjusted to contain ${INSTALL_PATH}/lib/vtk-5.8. Perhaps the module load command given in the comments to the rhel6.platform file should be added to dolfin.conf as well.

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

Thank you for the detailed report. I have incorporated your fixes as summarized below:

1. I added the boost-openmpi packages to the yum install list.
2, 4. I've corrected the instructions with your notes.
3. This was previously fixed in the development version of Dorsal, and was caused by a recent change in the development model of DOLFIN.
5. I will file a separate bug for this in DOLFIN.

Changed in dorsal:
status: New → Fix Committed
assignee: nobody → Harish Narayanan (hnarayanan)
milestone: none → 1.0
Changed in dorsal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers