failed to build because of but in trilinos

Bug #857300 reported by Michele Marcionelli on 2011-09-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dorsal
Fix Released
Medium
Harish Narayanan

Bug Description

I installed FEniCS 1.0-beta on Fedora 15 (x86_64) using dorsal.sh. But I had problems with a bug(?) included in trilinos; after compiling for about 5 minutes I got following error message:

Scanning dependencies of target teuchos
make[2]: Leaving directory `/usr/local/fenics/SRC/fenics-1.0-beta/trilinos-10.6.4-Source/dorsal_build_dir'
make[2]: Entering directory `/usr/local/fenics/SRC/fenics-1.0-beta/trilinos-10.6.4-Source/dorsal_build_dir'
[ 0%] Building CXX object packages/teuchos/src/CMakeFiles/teuchos.dir/Teuchos_BLAS.cpp.o
In file included from /usr/local/fenics/SRC/fenics-1.0-beta/trilinos-10.6.4-Source/packages/teuchos/src/Teuchos_BLAS.hpp:73:0,
                 from /usr/local/fenics/SRC/fenics-1.0-beta/trilinos-10.6.4-Source/packages/teuchos/src/Teuchos_BLAS.cpp:29:
/usr/local/fenics/SRC/fenics-1.0-beta/trilinos-10.6.4-Source/packages/teuchos/src/Teuchos_ConfigDefs.hpp:128:9: error: ‘ptrdiff_t’ does not name a type
/usr/local/fenics/SRC/fenics-1.0-beta/trilinos-10.6.4-Source/packages/teuchos/src/Teuchos_ConfigDefs.hpp:131:29: error: ‘Teuchos_Ordinal’ does not name a type
/usr/local/fenics/SRC/fenics-1.0-beta/trilinos-10.6.4-Source/packages/teuchos/src/Teuchos_ConfigDefs.hpp:135:9: error: ‘Teuchos_Ordinal’ does not name a type
make[2]: *** [packages/teuchos/src/CMakeFiles/teuchos.dir/Teuchos_BLAS.cpp.o] Error 1
make[1]: *** [packages/teuchos/src/CMakeFiles/teuchos.dir/all] Error 2
make: *** [all] Error 2

Fortunately I already found a patch (for an older version of trilinos, which worked for me); see here:
bug report => http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=625027
patch => http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=12;filename=trilinos_gcc46_build.fix;att=1;bug=625027

After applying the patch, I had to remove the "dorsal_build_dir" in "trilinos-10.6.4-Source" and run ./dorsal.sh again.

Questions:
1) Could you integrate that patch in dorsal, like here dorsal-1.0-beta/FEniCS/patches/?
2) Could you add the platform "Fedora release 15 (Lovelock)" to the supported platforms? I used the fedora14.platform and worked fine.

Regards, Michele

Changed in dorsal:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Harish Narayanan (hnarayanan)
milestone: none → 1.0
Changed in dorsal:
status: In Progress → Fix Committed
Harish Narayanan (hnarayanan) wrote :

I have incorporated both your suggestions. Thank you!

Changed in dorsal:
milestone: 1.0 → 1.0-beta2
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers