Petsc (and Slepc) not working on lion

Bug #852617 reported by Harish Narayanan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dorsal
Fix Released
High
Harish Narayanan

Bug Description

DOLFIN configure is fails to find Petsc (and Slepc) because the linker fails on the test file.

Revision history for this message
Harish Narayanan (hnarayanan) wrote :
Revision history for this message
Johannes Ring (johannr) wrote :

Configuring PETSc with --with-shared=1 does not work in PETSc 3.2 so it is trying to link with the static library libpetsc.a. Try to build PETSc with --with-shared-libraries=1 instead.

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

But I am not trying with petsc 3.2. I believe it is still petsc-3.1-p8 in dorsal.

Revision history for this message
Johannes Ring (johannr) wrote :

Ah, sorry! But it is still using the the static PETSc library /Users/harish/Work/FEniCS/dev/lib/libpetsc.a. Do you also have a libpetsc.dylib in that directory? If not, try to figure out why PETSc wasn't built with shared libraries.

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

There are no .dylib files in that directory, only .a files. I think this is because clang has replaced gcc as the default compiler and it perhaps uses different command line options to indicate static vs. shared builds.

Will investigate some more.

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

I had to mess a little with the petsc make system to get a dylib to build. The following is what worked for me:

--- conf/rules~ 2011-03-17 20:16:08.000000000 +0100
+++ conf/rules 2011-09-21 08:51:19.000000000 +0200
@@ -921,6 +921,7 @@
 shared_darwin8: shared_darwin7
 shared_darwin9: shared_darwin7
 shared_darwin10: shared_darwin7
+shared_darwin11: shared_darwin7

 shared_darwin7:
  -@cd ${SHARED_LIBRARY_TMPDIR}; \

Changed in dorsal:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Harish Narayanan (hnarayanan)
milestone: none → 1.0
Changed in dorsal:
status: Confirmed → Fix Committed
Revision history for this message
Garth Wells (garth-wells) wrote :

Perhaps a good fix would be to move to PETSc 3.2? I would expect that the newew PETSc build system will better support Lion.

SLEPc 3.2 is not out yet, but slepc-dev works fine against PETSc 3.2 and DOLFIN.

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

Yes, and I will move to PETSc 3.2 after SLEPc 3.2 is released. I don't want to (re)introduce a slepc-dev package so close to FEniCS 1.0.

Revision history for this message
Anders Logg (logg) wrote : Re: [Bug 852617] Re: Petsc (and Slepc) not working on lion

On Wed, Sep 21, 2011 at 10:11:32AM -0000, Harish Narayanan wrote:
> Yes, and I will move to PETSc 3.2 after SLEPc 3.2 is released. I don't
> want to (re)introduce a slepc-dev package so close to FEniCS 1.0.

Does anyone know when SLEPc 3.2 will be released?

--
Anders

Revision history for this message
Garth Wells (garth-wells) wrote :

On 21 September 2011 12:35, Anders Logg <email address hidden> wrote:
> On Wed, Sep 21, 2011 at 10:11:32AM -0000, Harish Narayanan wrote:
>> Yes, and I will move to PETSc 3.2 after SLEPc 3.2 is released. I don't
>> want to (re)introduce a slepc-dev package so close to FEniCS 1.0.
>
> Does anyone know when SLEPc 3.2 will be released?
>

Don't hold your breath, the SLEPc devs have been slow to release in the past.

Garth

> --
> Anders
>
> --
> You received this bug notification because you are a member of Dorsal
> Core Team, which is subscribed to Dorsal.
> https://bugs.launchpad.net/bugs/852617
>
> Title:
>  Petsc (and Slepc) not working on lion
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/dorsal/+bug/852617/+subscriptions
>

Changed in dorsal:
milestone: 1.0 → 1.0-beta2
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers