armadillo is not working

Bug #586741 reported by Aron Wahlberg
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DOLFIN
Undecided
Unassigned
Dorsal
Fix Released
Undecided
Unassigned

Bug Description

installation stops in dolfin with the message 'Unknown dependency package: armadillo' even though the package exists.

Related branches

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

Yes, this is a known problem on Mac OS X. I had to make some changes to the DOLFIN pkgconfiggenerators to get this to work. I have attached a file to this response, and you should save it over scons/simula-scons/simula_scons/pkgconfiggenerators/armadillo.py in your DOLFIN source.

Try it and let me know how it goes. Soon, this will make it to the main DOLFIN source tree.

Revision history for this message
Johannes Ring (johannr) wrote :

Aron, could you attach $DOLFIN_DIR/scons/simula_scons.log to this bug report?

Harish: I don't see this problem on the Mac buildbot. It's using the latest package from macports.

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

What is the macports armadillo package name? It doesn't show up in a cursory search.

Revision history for this message
Aron Wahlberg (aron-simula) wrote :

here's the log file

Revision history for this message
Aron Wahlberg (aron-simula) wrote :

Harish, your file (above) solved my problem.

Revision history for this message
Johannes Ring (johannr) wrote :

Harish: Sorry, I meant "It's using the latests packages from macports". There is no package for Armadillo AFAIK.

Aron: Thanks for the log file but it doesn't seem to be anything wrong. Did you apply Harish's patch? Anyway, I just tried to build DOLFIN with Dorsal on the Mac buildbot and I ran into the same problem. I will look into it.

Changed in dolfin:
status: New → Confirmed
Revision history for this message
Johannes Ring (johannr) wrote :

It seems that adding "-framwork vecLib" to the libs string solved the problem. Can someone confirm (see attached patch)?

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

No, it doesn't work. The test program still doesn't find boost libraries. I have attached the log file.

Revision history for this message
Johannes Ring (johannr) wrote :

Okay, I guess the difference is that I use gcc43 from macports and /opt/local/include is therefore already in the compilers search path. I have updated the patch to depend on Boost. Can you try it out?

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

No, this doesn't work either. It still doesn't find boost.

Revision history for this message
Johannes Ring (johannr) wrote :

Okay, but it did get you a little bit further. Please try the updated patch.

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

Success! Please push this updated pkgconfiggenerator to DOLFIN.

Johannes Ring (johannr)
Changed in dolfin:
status: Confirmed → Fix Committed
Changed in dolfin:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in dorsal:
status: New → Fix Committed
Revision history for this message
Aron Wahlberg (aron-simula) wrote :

no, that still doesn't make it for me.
I have now set up one stable and one unstable build of dolfin on my laptop.
The stable build is fine. For the unstable build I've tried both Harish's first patch that made it for in earlier attempts and Johanne's latest patch that he pushed to dolfin.

Here's the end of my build output (I tried the log file but it didn't say much (two lines only))

cdm -lpetscmat -lpetscvec -lpetsc -lX11 -lgmp -lgmpxx -lptscotch -lptscotcherr -framework vecLib -framework vecLib -framework vecLib -framework vecLib
ld: library not found for -lboost_thread
collect2: ld returned 1 exit status
scons: *** [dolfin/libdolfin.dylib] Error 1
mpic++ -o dolfin/swig/cpp_wrap.os -c -Wall -pipe -ansi -BOOST_UBLAS_NDEBUG -O3 -DHAS_MPI=1 -DMPICH_IGNORE_CXX_SEEK -DPACKAGE_VERSION=\"0.9.7\" -DHAS_CGAL=1 -DHAS_UMFPACK=1 -DHAS_CHOLMOD=1 -DHAS_LAPACK=1 -DHAS_SLEPC=1 -DHAS_ZLIB=1 -DHAS_MTL4=1 -DHAS_PETSC=1 -DHAS_GMP=1 -DHAS_SCOTCH=1 -fno-strict-aliasing -fno-strict-aliasing -frounding-math -DMTL_HAS_BLAS -fPIC -I. -I/Users/aron/bzr/FEniCS/unstable/include -I/opt/local/include -I/opt/local/include -I/opt/local/include -I/opt/local/include/libxml2 -I/Users/aron/bzr/FEniCS/unstable/include -I/opt/local/include -I/opt/local/include -I/opt/local/include/ufsparse -I/opt/local/include/ufsparse -I/Users/aron/bzr/FEniCS/unstable -I/Users/aron/bzr/FEniCS/unstable/include -I/Users/aron/bzr/FEniCS/unstable/include -I/usr/include -I/Users/aron/bzr/FEniCS/unstable/src/mtl4 -I/opt/local/include -I/Users/aron/bzr/FEniCS/unstable/include -I/Users/aron/bzr/FEniCS/unstable/include -I/opt/local/include -I/Users/aron/bzr/FEniCS/unstable/include -I/opt/local/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6 -I/opt/local/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6 -I/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/numpy/core/include -I/Users/aron/bzr/FEniCS/unstable/include -I/opt/local/include -I/opt/local/include -I/opt/local/include -I/opt/local/include/libxml2 -I/Users/aron/bzr/FEniCS/unstable/include -I/opt/local/include -I/opt/local/include -I/opt/local/include/ufsparse -I/opt/local/include/ufsparse -I/Users/aron/bzr/FEniCS/unstable -I/Users/aron/bzr/FEniCS/unstable/include -I/Users/aron/bzr/FEniCS/unstable/include -I/usr/include -I/Users/aron/bzr/FEniCS/unstable/src/mtl4 -I/opt/local/include -I/Users/aron/bzr/FEniCS/unstable/include -I/Users/aron/bzr/FEniCS/unstable/include -I/opt/local/include -I/Users/aron/bzr/FEniCS/unstable/include dolfin/swig/cpp_wrap.cc
scons: building terminated because of errors.
dolfin/libdolfin.dylib failed: Error 1
Failure with exit status: 2
Exit message: There was a problem building dolfin.

Revision history for this message
Harish Narayanan (hnarayanan) wrote :

Good, this is a separate bug you should file with DOLFIN. Someone (likely Johannes!) has to replace boost_thread with boost_thread-mt somewhere.

Changed in dolfin:
status: Fix Committed → Fix Released
Changed in dorsal:
milestone: none → 0.7.2
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers