Dolphin opens file/folder and menu on right click

Bug #212183 reported by Lydia Pintscher on 2008-04-05
8
Affects Status Importance Assigned to Milestone
dolphin
Invalid
Undecided
Unassigned
kdebase-kde4 (Ubuntu)
Low
Harald Sitter

Bug Description

When clicking on a file or folder with the right mouse button Dolphin opens the file/folder and the menu.
I am not sure if this is a problem with my installation or a general problem in Hardy.

I converted this question to bug.
It has been confirmed by someone else on IRC.
He has the same problem and also tried it with another mouse. The problem still exists.

mykrob (myk-robinson) wrote :

I can confirm this, i wan on IRC last night asking about the same issue. Seems that it surfaced after a recent update, as this hasnt not happened over the past two weeks, just started yesterday. This was on my laptop. I tried using an external mouse to make sure there wasnt a problem with my touchpad buttons. I get the same results either way.

I did note that holding the right button longer brings the proper menu, but would definitely prefer the quick right click i'm used to.

This behavior seems isolated to Dolphin. RIght clicking inside other applications works just fine.

I noticed it on 28.3. for the first time.
I did updates regularly and rebooted every day or every second day.
So I guess earliest this bug could have gotten in is 26.3.

(It also happens for me in Konqueror with the Dolphin view.)

Changed in dolphin:
status: New → Confirmed
mykrob (myk-robinson) wrote :

Problem still even after several updates. Are others not experiencing this?

Harald Sitter (apachelogger) wrote :

It probably makes more sense to file this for the Ubuntu package rather than an unused LP project ;-)

Changed in dolphin:
status: Confirmed → Invalid
Harald Sitter (apachelogger) wrote :

If Lydia is right, this issue would have been introduced 4:4.0.2-0ubuntu6, which is possible, but I doubt it since it would have been reported more often.

Changed in kdebase-kde4:
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → apachelogger
Kenobi (kazmirzak) wrote :

I have the same problem with the standard KDE 4 Kubuntu 8.04 installation.

A fix is REALLY needed!

Kenobi

Seems to be fixed for me in KDE 4.0.4
Is anyone still having this problem? Or is it gone for the rest as well?

Changed in kdebase-kde4:
status: Confirmed → Incomplete
Kenobi (kazmirzak) wrote :

Yeah, THIS problem is gone,

only now, as I only downloaded the dolphin package, it crashes when I rightclick somewhere, due to a silly dependency problem. I couldnt yet figure out what it needs, it only says:

symbol lookup error: dolphin: undefined symbol: _ZN15KonqMenuActionsD1Ev

that is not satisfiable. Do I always have to download 100MB... just to be sure?? OK, I can try downloading all of them, but then we don't need a packaging system any longer.

I'll try to find the missing package dependency...

Kenobi

Thank you for your confirmation.
Please file a new bug report if you can't solve your other problem.

Changed in kdebase-kde4:
status: Incomplete → Fix Released
Project Neon (project-neon) wrote :

The lookup issue is probably caused by an incomplete update, try switching the archive mirror in adept.

Kenobi (kazmirzak) wrote :

yes, it is definitively caused by an incomplete update, as I only wanted to update *some* packages. However, after doing the full update all seems to work now.

Still I don't like the idea to be forced to update *everything* just to be sure my system will work afterwards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers