plot segfaults when X is not available

Reported by Garth Wells on 2011-11-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DOLFIN
Undecided
Joachim Haga

Bug Description

When running demos remotely without X forwarding, plot commands cause a seg fault. It should be possible to test for an X display or to catch the error if there is no X. This may well be a Viper bug.

Changed in dolfin:
status: New → Confirmed
Garth Wells (garth-wells) wrote :

Viper has been retired, marking as won't fix.

Changed in dolfin:
status: Confirmed → Won't Fix
Benjamin Kehlet (benjamik) wrote :

Unfortunately the problem is still there with the new implementation.
I couldn't find any way in VTK to check that an X server is available. Is it possible to use the DISPLAY environment variable? And is it robust? And is it the kind of code you want in Dolfin?

On Fri, Jul 27, 2012 at 09:40:00AM -0000, Benjamin Kehlet wrote:
> Unfortunately the problem is still there with the new
> implementation. I couldn't find any way in VTK to check that an X
> server is available. Is it possible to use the DISPLAY environment
> variable? And is it robust? And is it the kind of code you want in
> Dolfin?

Checking the DISPLAY variable should be OK I think. At least that's
what Xterm does:

  xterm Xt error: Can't open display:
  xterm: DISPLAY is not set

--
Anders

Benjamin Kehlet (benjamik) wrote :

Ok, but don't we need to check the the platform as well?

Joachim Haga (jobh) on 2012-09-28
Changed in dolfin:
assignee: nobody → Joachim Haga (jobh)
Joachim Haga (jobh) wrote :

Fixed in trunk. Not allowed to change bug status.

Changed in dolfin:
status: Won't Fix → Fix Committed
Changed in dolfin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints