Missing test for boost/bimap.hpp

Bug #493091 reported by Anders Logg on 2009-12-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DOLFIN
High
Johannes Ring

Bug Description

The buildbots are complaining on a missing Boost header file:

dolfin/mesh/IntersectionOperatorImplementation.h:15:27: error: boost/bimap.hpp: No such file or directory

This needs to be added to the config/testing of DOLFIN. The file is in libboost-dev.

Anders Logg (logg) on 2009-12-06
Changed in dolfin:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Johannes Ring (johannr)
Garth Wells (garth-wells) wrote :

CGAL will also need to be installed on the build bots to have them turn green.

Changed in dolfin:
milestone: none → 0.9.6
Johannes Ring (johannr) wrote :

Is it really necessary to include this file? I tried to remove it (line 15) and DOLFIN compiled just fine without it. It would be good to not depend on this file since it is not available in the Boost libraries in Ubuntu Hardy and I would like to still provide debs for Hardy.

Johannes Ring wrote:
> Is it really necessary to include this file? I tried to remove it (line
> 15) and DOLFIN compiled just fine without it. It would be good to not
> depend on this file since it is not available in the Boost libraries in
> Ubuntu Hardy and I would like to still provide debs for Hardy.
>

No it is not (now). It has been thought to use bimaps as data structure
for some intersection maps. But it is not entirely clear yet, how the
extension may look like, so just remove it (but it may reappear the future).

Johannes Ring (johannr) on 2009-12-08
Changed in dolfin:
status: Confirmed → Fix Committed
Anders Logg (logg) on 2010-02-03
Changed in dolfin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers