Docky click area larger than visible in panel mode

Bug #730959 reported by Calcipher on 2011-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Docky
Wishlist
Robert Dyer

Bug Description

In the past, I have reported that the border of Docky (for windows snapping purposes Bug #517874), when in panel mode with icons set to 24, is much larger than the visible region of Docky. While annoying, this isn't a huge problem; however, recently the borders of Docky have begun to cover up the bottom of windows that are touching the Docky panel. This is interfering with many things, including the addons that place icons in Firefox's status bar. Bizarrely, it I approach an icon in the status bar from above, I can interact with it, if I approach it from below (where Docky is) I can only interact with Docky. Again, this is happening within approximately the same invisible region as the window snapping border, but is perhaps not the same bug as it is more recent.

Version: 2.2.0r1797
Distro: Ubuntu 10.10

Robert Dyer (psybers) wrote :

I love being able to use this phrase: this is not a bug, it is a feature.

Seriously, we planned it this way. However the devs have actually been discussing this feature recently and it might change a little bit. Basically it came about for docks with zoom enabled, so you cant so easily 'fall off' the dock (which causes it to unzoom, making you move really far to get back 'on' the dock).

We recently changed the behavior, so if you run our dev PPA or compile from source it is already 'fixed' (how we want it to be).

It used to be the extra area was 30% of the zoomed dock height. We changed it to a fixed size (default is 24px). It is also configurable (on a per-dock basis) via a GConf key:

/apps/docky-2/Docky/Interface/DockPreferences/DockN/HotAreaPadding

Fixed in rev 1789.

Changed in docky:
status: New → Fix Committed
importance: Undecided → Wishlist
assignee: nobody → Robert Dyer (psybers)
milestone: none → 2.0.12
Calcipher (calcipher) wrote :

So, revision 1797 should have the new behavior. I think the new behavior is actually what is causing me problems. Would the be any unforeseen problems if I set it to 0px?

Robert Dyer (psybers) wrote :

The new behavior and the old are the same, assuming you have a 48px icon size.

And no, setting it to 0 is fine. That's the point of making it a gconf key.

Calcipher (calcipher) wrote :

Thanks for your help, having it set to zero is much nicer.

Changed in docky:
milestone: 2.0.12 → none
Robert Dyer (psybers) on 2011-03-08
Changed in docky:
milestone: none → 2.2.0
Changed in docky:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers