[feature request] show windspeed in weather docklet

Bug #620783 reported by Chris S. on 2010-08-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Docky
Wishlist
Robert Dyer

Bug Description

In weather applet, wind speed displayed as km/h.
I'm Russian, and it's bit confused because we use m/s.

Excuse my English, hope you'll understand what i mean.

Chris S. (cszikszoy) on 2010-08-19
Changed in docky:
assignee: nobody → Robert Dyer (psybers)
importance: Undecided → Wishlist
Robert Dyer (psybers) wrote :

We will only support one of km/h or m/s. As far as I am aware (and keep in mind, I don't use metric for wind speed so I have to rely on Google) km/h is the more common of the two. If I am wrong, please provide solid evidence of that fact and I will switch the docklet to using m/s.

Changed in docky:
status: New → Won't Fix
vovkkk (vovkkk) wrote :

Why only one? why user can't choose what he want to see?

Solid evidence… There is International System of Units, so metre and second are part of it.
But kilometre and hour are not.

Also km/h uses in aviation because too large values.

Rico Tzschichholz (ricotz) wrote :

I think using km/h is more understandable, but looking at the gnome-applet it is showing the velocity in m/s as default and it gives you quite some choices.

So we might think about implementing some choices since there is already a preferences dialog where we can drop the metric/imperial choice and use two comboboxes for temperatures and velocities with (km/h - m/s - mph - beaufort) and (°C - °F - °K) and their localized defaults

Changed in docky:
status: Won't Fix → Confirmed
Robert Dyer (psybers) wrote :

Completely disagree. KISS. Metric vs non-metric only. And for metric (as I stated before) the most commonly used (outside of science) is km/hr.

Changed in docky:
status: Confirmed → Won't Fix
vovkkk (vovkkk) wrote :

Hey, Robert, as i said i'm Russian and we use m/s. And seems like in China and in Japan using m/s too. (there are very many people, absolutely more than who prefered km/h).
You can check it on iGoogle with weather gadget (changing language in Settings) and Google Translate.

By the way, what you'll say about atmospheric pressure and its units?

Robert Dyer (psybers) wrote :

We dont show pressure, so that is not an issue.

And as I said, if you can give me actual proof that m/s is more common than km/hr (which from everything I have googled, seems wrong) then I will switch it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions