Wine application launcher not working properly (window matching)

Bug #596092 reported by Svein Tore Seljebotn on 2010-06-18
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Docky
Low
Robert Dyer
docky (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

I am using this entry for launching Spotify using WINE:

[Desktop Entry]
Name=Spotify
Exec=padsp env WINEPREFIX="/home/sveint/.wine" wine "C:\\Programfiler\\Spotify\\spotify.exe"
Type=Application
StartupWMClass=Wine
Path=/home/sveint/.wine/dosdevices/c:/Programfiler/Spotify
Icon=cec6_spotify.0
Name[nb_NO]=Spotify.desktop

It launches Spotify, but it will show Spotify as a new icon on Docky, which is not the behaviour I expected. Another strange thing is that I cannot pin this newly created (and working) icon to Docky: the "Pin to dock" option doesn't show for this specific icon. So basically I have to have two spotify icons on Docky in order to have a Spotify launcher on Docky and Spotify running.

Another thing is that this new icon doesn't update window title properly. Sometimes it changes to currently playing song, sometimes not. Haven't found the trigger to make it update yet...

Docky version: 2.1.0 bzr docky r1490 ppa
Kernel version: 2.6.32.22
CLR version: 2.0.50727.1433

Svein Tore Seljebotn (sveint) wrote :

Might add that right-clicking on the icon shows one option for selecting a window, and this option has correct title...the icon does not...

Svein Tore Seljebotn (sveint) wrote :

ps output:

ps -ef | grep Spotify
sveint 5179 1 7 23:29 ? 00:01:00 C:\Programfiler\Spotify\spotify.exe

Robert Dyer (psybers) wrote :

Fixed the matching in rev 1497.

Changed in docky:
status: New → Fix Committed
milestone: none → 2.0.5
assignee: nobody → Robert Dyer (psybers)
importance: Undecided → Low
Robert Dyer (psybers) wrote :

Note that now that it should match properly, the window title will use the 'Name=' setting from the launcher.

Svein Tore Seljebotn (sveint) wrote :

xprop (clicking on Spotify window):

sveint@sveint-laptop:~$ xprop | grep WM_CLASS | awk '{print $4}'
"Wine"

Svein Tore Seljebotn (sveint) wrote :

Ok, thanks for the heads up and for fixing the bug.

However, I realize window matching is hard, but isn't not dynamically changing the window title kind of removing a feature? Same with not changing icons to Pidgins user icons from chat windows.

Just changed to Docky from AWN, and AWN does both these things without trouble...and it makes things look really nice.

Changed in docky:
status: Fix Committed → Fix Released
summary: - Wine application launcher not working properly (window matching)
+ debdiff which fixes this is attached to bug #579049
summary: - debdiff which fixes this is attached to bug #579049
+ Wine application launcher not working properly (window matching)
Rico Tzschichholz (ricotz) wrote :

debdiff which fixes this is attached to bug #579049

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package docky - 2.0.5-1

---------------
docky (2.0.5-1) unstable; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that don't have a...

Read more...

Changed in docky (Ubuntu):
status: New → Fix Released

Accepted docky into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in docky (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package docky - 2.0.5-0ubuntu1

---------------
docky (2.0.5-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that do...

Read more...

Changed in docky (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers