Dragging files to folders causes data "corruption"

Reported by beefstu on 2010-05-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Docky
Medium
Robert Dyer
docky (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

If you drag a group of files from the desktop into a folder on Docky, causes very strange behaviour.

For example, if you have 4 files, A, B, C and D, select them all, drag them over a folder and when it says "release to open" drop them to place them in the folder. File D gets moved to the folder but renamed A. libnotify (the notification app in Ubuntu) says "moving D... 00.0% Complete" and never disappears. No how long you leave it, nothing changes.

This bug could lead to loss of data as if you try to move the file back, it now has the same name as one of the other files!

docky -d:
[Info 00:58:18.676] Docky version: 2.0.2 Release
[Info 00:58:18.688] Kernel version: 2.6.32.22
[Info 00:58:18.689] CLR version: 2.0.50727.1433
[Debug 00:58:19.068] [UserArgs] BufferTime = 0
[Debug 00:58:19.068] [UserArgs] MaxSize = 2147483647
[Debug 00:58:19.068] [UserArgs] NetbookMode = False
[Debug 00:58:19.068] [UserArgs] NoPollCursor = False
[Info 00:58:19.200] [DockController] Setting theme: Classic
[Info 00:58:19.555] [PluginManager] Loaded "Trash".
[Info 00:58:19.580] [PluginManager] Loaded "Docky.Widgets,1.0".
[Info 00:58:19.580] [PluginManager] Loaded "Docky.Widgets,1.0".
[Info 00:58:19.581] [PluginManager] Loaded "Weather".
[Info 00:58:19.600] [PluginManager] Loaded "Mounter".
[Debug 00:58:19.643] [MountProvider] Adding SYSTEM RESERVED.
[Debug 00:58:19.645] [MountProvider] Adding PQSERVICE.
[Debug 00:58:19.648] [MountProvider] Adding Packard Bell.
[Debug 00:58:20.007] Key MountItem_140054933318656 does not exist, creating.
[Debug 00:58:20.015] Key MountItem_140054933318752 does not exist, creating.
[Debug 00:58:20.022] Key MountItem_140054933318848 does not exist, creating.
[Info 00:58:20.352] [AbstractWeatherSource] iGoogle: Reloading weather data
[Debug 00:58:20.365] [AbstractWeatherSource] iGoogle: Fetching XML file 'http://www.google.com/ig/api?hl=en&weather=Southampton%2c+UK'
[Debug 00:58:20.845] [AbstractWeatherSource] iGoogle: Fetching XML file 'http://api.wunderground.com/auto/wui/geo/WXCurrentObXML/index.xml?query=Southampton%2c+UK'
[Info 00:58:21.083] [DrawingService] Could not find 'gtg', using fallback of 'extension'.
[Debug 00:58:26.413] [AbstractWeatherSource] iGoogle: reload success
[Fatal 00:59:37.335] [Gtk] gtk_drag_dest_leave: assertion `site != NULL' failed
[Notify 00:59:39.957] - 0% Complete...
[Notify 00:59:39.966] - 0% Complete...
[Notify 00:59:39.966] - 0% Complete...
[Notify 00:59:39.967] - 0% Complete...
[Error 00:59:40.056] [SystemService] Error in RunOnThread: Error moving file: No such file or directory
[Debug 00:59:40.058] [SystemService] at GLib.FileAdapter.Move (File destination, FileCopyFlags flags, GLib.Cancellable cancellable, GLib.FileProgressCallback progress_callback) [0x00000]
  at Docky.Items.FileDockItem+<OnAcceptDrop>c__AnonStoreyE.<>m__29 () [0x00000]
  at Docky.Services.SystemService+<RunOnThread>c__AnonStorey9.<>m__F () [0x00000]
[Error 00:59:40.075] [SystemService] Error in RunOnThread: Error moving file: No such file or directory
[Debug 00:59:40.075] [SystemService] at GLib.FileAdapter.Move (File destination, FileCopyFlags flags, GLib.Cancellable cancellable, GLib.FileProgressCallback progress_callback) [0x00000]
  at Docky.Items.FileDockItem+<OnAcceptDrop>c__AnonStoreyE.<>m__29 () [0x00000]
  at Docky.Services.SystemService+<RunOnThread>c__AnonStorey9.<>m__F () [0x00000]
[Error 00:59:40.092] [SystemService] Error in RunOnThread: Error moving file: No such file or directory
[Debug 00:59:40.092] [SystemService] at GLib.FileAdapter.Move (File destination, FileCopyFlags flags, GLib.Cancellable cancellable, GLib.FileProgressCallback progress_callback) [0x00000]
  at Docky.Items.FileDockItem+<OnAcceptDrop>c__AnonStoreyE.<>m__29 () [0x00000]
  at Docky.Services.SystemService+<RunOnThread>c__AnonStorey9.<>m__F () [0x00000]

Running Linux Mint 9RC bassed on Ubunty 10.04, however was also present on Mint 8 based on Ubuntu 9.10.
Xorg version 1.7.6 (or 7.4?)
Video card independent (same results on system with Intel GMA and Nvidia cards)
Gnome 2.30
Mono 2.4.4

The folder doesn't matter which one it is but for the purposes of this example, it was the pictures folder (~/Pictures) which was empty before

Robert Dyer (psybers) on 2010-05-12
Changed in docky:
assignee: nobody → Chris S. (cszikszoy)
importance: Undecided → Medium
Robert Dyer (psybers) wrote :

Fixed in rev 1396.

Changed in docky:
status: New → Fix Committed
assignee: Chris S. (cszikszoy) → Robert Dyer (psybers)
Robert Dyer (psybers) on 2010-06-02
Changed in docky:
milestone: none → 2.0.5
Changed in docky:
status: Fix Committed → Fix Released
Rico Tzschichholz (ricotz) wrote :
Download full text (4.8 KiB)

Docky 2.0.5 was released recently and should be considered for a SRU!

bzr diff -r tag:2.0.4..tag:2.0.5 | filterdiff -x "*.po*" | diffstat
 AUTHORS | 3
 COPYRIGHT | 3
 Docky.Items/Docky.Items/AbstractDockItem.cs | 6
 Docky.Items/Docky.Items/ApplicationDockItem.cs | 32
 Docky.Items/Docky.Items/ColoredIconDockItem.cs | 2
 Docky.Items/Docky.Items/FileApplicationProvider.cs | 16
 Docky.Items/Docky.Items/FileDockItem.cs | 95 +-
 Docky.Items/Docky.Items/IconDockItem.cs | 80 -
 Docky.Items/Docky.Items/IconEmblem.cs | 20
 Docky.Items/Docky.Items/WnckDockItem.cs | 18
 Docky.Items/Docky.Menus/MenuItem.cs | 3
 Docky.Items/Docky.Painters/PagingDockPainter.cs | 1
 Docky.Services/Docky.Services.csproj | 1
 Docky.Services/Docky.Services/DrawingService.cs | 128 --
 Docky.Services/Docky.Services/Extensions/GLibFileExtension.cs | 2
 Docky.Services/Docky.Services/Extensions/GdkPixbufExtension.cs | 131 ++
 Docky.Services/Docky.Services/Helper.cs | 3
 Docky.Services/Docky.Services/HelperMetadata.cs | 9
 Docky.Services/Docky.Services/HelperService.cs | 131 +-
 Docky.Services/Docky.Services/SystemService.cs | 20
 Docky.Services/Makefile.am | 1
 Docky.Widgets/Docky.Widgets/AbstractTileObject.cs | 2
 Docky.Widgets/Docky.Widgets/SearchEntry.cs | 16
 Docky.Widgets/Docky.Widgets/Tile.cs | 29
 Docky.Widgets/Docky.Widgets/TileView.cs | 12
 Docky.Widgets/Docky.Widgets/WrapLabel.cs | 13
 Docky.Windowing/Windowing/WindowMatcher.cs | 36
 Docky/Docky/ConfigurationWindow.cs | 103 +-
 Docky/Docky/DockletTile.cs | 29
 Docky/Docky/Docky.cs | 94 +-
 Docky/Docky/HelperTile.cs | 33
 Docky/Docky/Interface/AutohideManager.cs | 23
 Docky/Docky/Interface/DockDragTracker.cs | 70 -
 Docky/Docky/Interface/DockPreferences.cs | 4
 Docky/Docky/Interface/DockWindow.cs | 446 +++++-----
 Docky/Docky/Interface/HoverTextManager.cs | 39
 Docky/Docky/Menus/DockMenu.cs | 3
 Docky/Docky/Menus/MenuItemWidget.cs | 92 +-
 Docky/Docky/Menus/SeparatorWidget.cs | 43
 Docky/docky.in | ...

Read more...

Rico Tzschichholz (ricotz) wrote :
Download full text (4.0 KiB)

debdiff docky_2.0.4-0ubuntu1.dsc docky_2.0.5-0ubuntu1.dsc | filterdiff -x "*.po*" > docky-205-sru-trimmed.debdiff

docky (2.0.5-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove dep...

Read more...

Rico Tzschichholz (ricotz) wrote :

This is the complete debdiff including translation updates.

Iain Lane (laney) wrote :

Thanks for your work.

Will be fixed in M by way of a sync (or pocket copy if the SRU team beats us)

John Dong (jdong) wrote :

Ok, looking at the trimmed debdiff, the fixes look reasonable. Given the nature of Docky, I'm +1 for this SRU.

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package docky - 2.0.5-1

---------------
docky (2.0.5-1) unstable; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that don't have a...

Read more...

Changed in docky (Ubuntu):
status: New → Fix Released

Accepted docky into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in docky (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

I have installed the docky from the proposed repository and dragged a group of files from the desktop into a folder on Docky. Works as expected.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package docky - 2.0.5-0ubuntu1

---------------
docky (2.0.5-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that do...

Read more...

Changed in docky (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers