Clock context menu not indicating state of options

Bug #574003 reported by Dag Odenhall
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Docky
Low
Robert Dyer
docky (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Unassigned

Bug Description

For example, to get an analogue clock when we have a digital clock, one needs to click the option for a digital clock - which has no indication of being enabled, so clicking doesn't feel like disabling.

Revision history for this message
Robert Dyer (psybers) wrote :

Fixed in rev 1317.

Changed in docky:
importance: Undecided → Low
assignee: nobody → Robert Dyer (psybers)
status: New → Fix Committed
Changed in docky:
status: Fix Committed → Fix Released
Iain Lane (laney)
Changed in docky (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
Changed in docky (Ubuntu):
status: New → Fix Released
Revision history for this message
Iain Lane (laney) wrote :

I'm going to use this bug to track the SRU.

This is a new upstream release which we want to get into Lucid. A lot of the diff is translation changes due to line number alterations caused by the other fixes. I'm attaching a cut down debdiff which should help with the review.

laney@chicken> bzr diff -r tag:2.0.2-1 | filterdiff -x "*po" | diffstat
 Docky.DBus/Docky.DBus/DockyDBusItem.cs | 19 +-
 Docky.Items/Docky.Items/AbstractDockItem.cs | 175 ++++++++++-----------
 Docky.Items/Docky.Items/ApplicationDockItem.cs | 6
 Docky.Items/Docky.Items/FileApplicationProvider.cs | 68 +++++---
 Docky.Items/Docky.Items/IconDockItem.cs | 28 ++-
 Docky.Items/Docky.Items/IconEmblem.cs | 7
 Docky.Items/Docky.Items/WindowDockItem.cs | 8
 Docky.Items/Docky.Menus/IconMenuItem.cs | 1
 Docky.Items/Docky.Menus/MenuItem.cs | 16 +
 Docky.Items/Docky.Menus/MenuList.cs | 14 +
 Docky.Items/Docky.Painters/PagingDockPainter.cs | 3
 Docky.Services/AssemblyInfo.cs | 4
 Docky.Services/Docky.Services/Preferences.cs | 120 ++++++++------
 Docky.Services/Docky.Services/SystemService.cs | 29 ++-
 Docky.Widgets/Docky.Widgets/AbstractTileObject.cs | 17 +-
 Docky.Widgets/Docky.Widgets/AnimatedBox.cs | 9 -
 Docky.Widgets/Docky.Widgets/ListOnlyTileView.cs | 4
 Docky.Widgets/Docky.Widgets/Tile.cs | 56 +++++-
 Docky.Widgets/Docky.Widgets/TileView.cs | 69 ++++++--
 Docky.Windowing/Windowing/DesktopItem.cs | 7
 Docky.Windowing/Windowing/WindowMatcher.cs | 14 +
 Docky/AssemblyInfo.cs | 6
 Docky/Docky/DockletTile.cs | 8
 Docky/Docky/Docky.cs | 4
 Docky/Docky/HelperTile.cs | 19 +-
 Docky/Docky/Interface/DockWindow.cs | 18 +-
 Docky/Docky/Items/DockyItem.cs | 1
 Docky/Docky/Menus/DockItemMenu.cs | 12 +
 Docky/Docky/Menus/MenuItemWidget.cs | 9 +
 Makefile.am | 5
 Makefile.in | 8
 NEWS | 106 ++++++++++++
 StandardPlugins/Clock/src/ClockDockItem.cs | 6
 StandardPlugins/GMail/src/GMailAtom.cs | 13 +
 configure | 20 +-
 configure.ac | 2
 debian/changelog | 34 ++++
 debian/control | 6
 debian/rules | 5
 scripts/docky/docky.py | 40 ++--
 scripts/docky/docky.py.in | 40 ++--
 41 files changed, 748 insertions(+), 288 deletions(-)

Revision history for this message
Iain Lane (laney) wrote :

SRU team, please have a look at this. Upstream has kindly supplied this release intending for it to make it to Lucid users, so it would be nice if we could have a smooth approval for the SRU. Sufficient details should be on proposed closed bugs.

Revision history for this message
Iain Lane (laney) wrote :

Of course, I have done the appropriate install/uninstall/upgrade/build/functionality testing. I see no regressions.

Changed in docky:
milestone: none → 2.0.3
Revision history for this message
Rico Tzschichholz (ricotz) wrote :

Docky 2.0.4 was released recently and should be considered for a SRU!

bzr diff -r tag:2.0.3.1 | filterdiff -x "*po" | diffstat
 AUTHORS | 2
 Docky.Items/Docky.Items/AbstractDockItem.cs | 9
 Docky.Items/Docky.Items/ApplicationDockItem.cs | 7
 Docky.Items/Docky.Items/FileApplicationProvider.cs | 132 +++++-
 Docky.Items/Docky.Items/FileDockItem.cs | 39 +-
 Docky.Items/Docky.Items/WnckDockItem.cs | 19
 Docky.Services/Docky.Services/DockServices.cs | 5
 Docky.Services/Docky.Services/Helper.cs | 132 +++---
 Docky.Services/Docky.Services/HelperService.cs | 44 +-
 Docky.Services/Docky.Services/Log.cs | 2
 Docky.Services/Docky.Services/Logging/LogBase.cs | 11
 Docky.Services/Docky.Services/SystemService.cs | 16
 Docky.Widgets/Docky.Widgets/ListOnlyTileView.cs | 4
 Docky.Widgets/Docky.Widgets/TileView.cs | 6
 Docky.Windowing/Windowing/WindowMatcher.cs | 4
 Docky/Docky/ConfigurationWindow.cs | 3
 Docky/Docky/Docky.cs | 3
 Docky/Docky/HelperTile.cs | 4
 Docky/Docky/Interface/DockWindow.cs | 5
 Docky/Docky/Interface/HoverTextManager.cs | 4
 Docky/Docky/Menus/DockMenu.cs | 4
 Docky/gtk-gui/Docky.ConfigurationWindow.cs | 4
 Docky/gtk-gui/gui.stetic | 2
 NEWS | 105 +++--
 StandardPlugins/Clock/src/ClockDockItem.cs | 54 +-
 StandardPlugins/GMail/gtk-gui/GMail.GMailLabelConfig.cs | 2
 StandardPlugins/GMail/gtk-gui/gui.stetic | 2
 StandardPlugins/GMail/src/GMailAtom.cs | 2
 StandardPlugins/GMail/src/GMailDockItem.cs | 34 +
 StandardPlugins/NPR/src/Station.cs | 41 +-
 StandardPlugins/NPR/src/StationDockItem.cs | 10
 StandardPlugins/RecentDocuments/src/RecentDocumentsItem.cs | 30 -
 StandardPlugins/Trash/src/TrashDockItem.cs | 4
 StandardPlugins/Weather/src/WeatherPreferences.cs | 24 +
 configure.ac | 2
 po/POTFILES.in | 1
 po/docky.pot | 250 ++++++-------
 scripts/banshee_control.py | 19
 scripts/deluge_badge.py | 8
 scripts/open_terminal_here.py | 10
 scripts/rhythmbox_control.py | 26 -
 scripts/zeitgeist_docky.py | 65 ++-
 42 files changed, 734 insertions(+), 416 deletions(-)

Revision history for this message
Rico Tzschichholz (ricotz) wrote :

debdiff docky_2.0.2-1.dsc docky_2.0.4-0ubuntu1.dsc | filterdiff -x "*po" > docky-204-sru-trimmed.debdiff

Revision history for this message
Martin Pitt (pitti) wrote :

Very big patch, but the individual bugs and fixes seem appropriate. Please get it uploaded.

Revision history for this message
Scott Kitterman (kitterman) wrote : Please test proposed package

Accepted into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in docky (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Revision history for this message
Rico Tzschichholz (ricotz) wrote :

All bugs are mostly found by people who using our ppa, so they got backported to our stable 2.0.x branch which is working well. Also it is hard to get a confirmation on every bug report. So here a some important examples to support this SRU to be verified.

Examples of fixed bugs in 2.0.4 since 2.0.2:

crash accessing Gnome keyring in Lucid
https://bugs.edge.launchpad.net/docky/+bug/555562/comments/16

Crash when active window is changing
https://bugs.edge.launchpad.net/docky/+bug/581280/comments/3

Two Icons Showing for Two Openoffice Writer Windows
https://bugs.edge.launchpad.net/docky/+bug/486887/comments/18

Docky popup spans multiple monitors
https://bugs.edge.launchpad.net/docky/+bug/544047/comments/7

Docky crashes when right clicking and selecting open
https://bugs.edge.launchpad.net/docky/+bug/581074/comments/6

Docky doesn't show windows dragged from another desk when CurrentDesktopOnly is enabled
https://bugs.edge.launchpad.net/docky/+bug/581077/comments/11

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted docky into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in docky (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers