No right-click options in Lucid x64

Reported by coburn ingram on 2010-05-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Docky
Medium
Robert Dyer
docky (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

In a fresh install of Lucid x64 right-click does nothing on any icon. I've combed through the configuration editor -- my desktop wasn't right-clicking either but I fixed that. Here's what docky --debug says when I right-click the OpenOffice icon when it's running.

[Error 08:20:06.056] [AbstractDockItem] An exception was thrown by the type initializer for Docky.Menus.MenuItem
[Debug 08:20:06.056] [AbstractDockItem] at Docky.Items.WnckDockItem.OnGetMenuItems () [0x00000]
  at Docky.Items.ApplicationDockItem.OnGetMenuItems () [0x00000]
  at Docky.Items.AbstractDockItem.GetMenuItems () [0x00000]

Actually right-clicking the icon of a running application that isn't on the dock causes Docky to crash altogether.

[Error 08:24:52.151] [AbstractDockItem] An exception was thrown by the type initializer for Docky.Menus.MenuItem
[Debug 08:24:52.152] [AbstractDockItem] at Docky.Items.WnckDockItem.OnGetMenuItems () [0x00000]
  at Docky.Items.ApplicationDockItem.OnGetMenuItems () [0x00000]
  at Docky.Items.AbstractDockItem.GetMenuItems () [0x00000]
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.TypeInitializationException: An exception was thrown by the type initializer for Docky.Menus.MenuItem ---> System.InvalidCastException: Cannot cast from source type to destination type.
  at Docky.Menus.MenuItem..cctor () [0x00000]
  --- End of inner exception stack trace ---
  at Docky.Items.WnckDockItem.OnGetMenuItems () [0x00000]
  at Docky.Items.ApplicationDockItem.OnGetMenuItems () [0x00000]
  at Docky.Items.AbstractDockItem.GetMenuItems () [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.buttonpressevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Docky.Docky.Main(System.String[] args)
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose

I'm using Compiz and have set windows to come up on mouseover. Pretty sure that's irrelevant.

Robert Dyer (psybers) wrote :

I have no idea whats causing this. I could probably trap the exception but then I'm guessing you will just get empty menus.

This is probably related to 64bit mono, which I do not use. I'll have to try and find someone else on 64bit who has this problem to confirm.

Changed in docky:
importance: Undecided → Medium
assignee: nobody → Jason Smith (jassmith)

One thing I haven't tried is scrapping my compiz configuration and
starting over. I'll keep tinking around with it. Thanks.

2010/5/2, Robert Dyer <email address hidden>:
> I have no idea whats causing this. I could probably trap the exception
> but then I'm guessing you will just get empty menus.
>
> This is probably related to 64bit mono, which I do not use. I'll have
> to try and find someone else on 64bit who has this problem to confirm.
>
> ** Changed in: docky
> Importance: Undecided => Medium
>
> ** Changed in: docky
> Assignee: (unassigned) => Jason Smith (jassmith)
>
> --
> No right-click options in Lucid x64
> https://bugs.launchpad.net/bugs/573751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Robert Dyer (psybers) wrote :

Is anyone else experiencing this bug?

@coburn: is this still occurring with revision 1360?

Changed in docky:
status: New → Incomplete
Robert Dyer (psybers) wrote :

@coburn: still having issues?

coburn ingram (coby-peru) wrote :

Yeah. Haven't spent a whole lot of time on it either. Thanks for checking.

2010/6/5, Robert Dyer <email address hidden>:
> @coburn: still having issues?
>
> --
> No right-click options in Lucid x64
> https://bugs.launchpad.net/bugs/573751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Robert Dyer (psybers) wrote :

I'd love to know what is unique about your setup, as no one else seems to be encountering this bug.

This is the main problem here "An exception was thrown by the type initializer for Docky.Menus.MenuItem" but I do not know what is causing it for you. But basically it is having troubles loading the menu item class and without that, menus cant work.

You are running the latest bzr trunk or PPA right?

Robert Dyer (psybers) wrote :

Ok we found the problem. As a temporary workaround, run this:

  gconftool-2 --type bool --set /desktop/gnome/interface/menus_have_icons true

Robert Dyer (psybers) wrote :

Fixed in rev 1530.

Changed in docky:
assignee: Jason Smith (jassmith) → Robert Dyer (psybers)
status: Incomplete → Fix Committed
milestone: none → 2.0.5
Changed in docky:
status: Fix Committed → Fix Released
coburn ingram (coby-peru) wrote :

Woot! Thank you!

2010/7/1, Rico Tzschichholz <email address hidden>:
> ** Changed in: docky
> Status: Fix Committed => Fix Released
>
> --
> No right-click options in Lucid x64
> https://bugs.launchpad.net/bugs/573751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

summary: - No right-click options in Lucid x64
+ debdiff which fixes this is attached to bug #579049
summary: - debdiff which fixes this is attached to bug #579049
+ No right-click options in Lucid x64
Rico Tzschichholz (ricotz) wrote :

debdiff which fixes this is attached to bug #579049

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package docky - 2.0.5-1

---------------
docky (2.0.5-1) unstable; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that don't have a...

Read more...

Changed in docky (Ubuntu):
status: New → Fix Released

Accepted docky into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in docky (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package docky - 2.0.5-0ubuntu1

---------------
docky (2.0.5-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that do...

Read more...

Changed in docky (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers