Firefox as launcher duplicate icon

Bug #551748 reported by Jesus Manuel on 2010-03-30
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Docky
Low
Robert Dyer

Bug Description

Hello, when launching Firefox from an icon in Docky, duplicates icon. Docky is not using the launcher Firefox icon to manage open Firefox windows and is creating another icon to do this.

Was working well until 28-3-2010. I didn't made any changes to my Linux installation (only updated Docky to latest PPA one, 1222). This is happening in two different machines with Ubuntu 9.10 Karmic with Gnome 2.28, and Firefox 3.5.8 & 3.6

Thanks in advance.

$ docky -d output:

[Info 16:39:48.248] Docky version: 2.1.0 bzr docky r1222 ppa
[Info 16:39:48.264] Kernel version: 2.6.31.20
[Info 16:39:48.266] CLR version: 2.0.50727.1433
[Warn 16:39:48.548] [GLib] g_set_prgname() called multiple times
/usr/share/themes/Human/gtk-2.0/gtkrc:85: Murrine configuration option "gradients" is no longer supported and will be ignored.
[Debug 16:39:49.075] [UserArgs] BufferTime = 0
[Debug 16:39:49.076] [UserArgs] MaxSize = 2147483647
[Debug 16:39:49.076] [UserArgs] NetbookMode = False
[Debug 16:39:49.076] [UserArgs] NoPollCursor = False
[Info 16:39:49.289] [DockController] Setting theme: Glass
[Info 16:39:49.715] [PluginManager] Loaded "Docky.Widgets,1.0".
[Info 16:39:49.716] [PluginManager] Loaded "Docky.Widgets,1.0".
[Info 16:39:49.717] [PluginManager] Loaded "Clock".
[Info 16:39:49.728] [PluginManager] Loaded "Trash".
[Info 16:39:49.761] [PluginManager] Loaded "Session Manager".
[Debug 16:39:49.767] [SystemManager] Using DeviceKit.Power dbus service
[Debug 16:39:49.770] [SystemManager] Using ConsoleKit.Manager dbus service
[Info 16:39:50.896] [Helper] Starting rhythmbox_control.py
[Info 16:39:51.034] [Helper] Starting liferea_badge.py

Robert Dyer (psybers) on 2010-03-30
Changed in docky:
importance: Undecided → Low
assignee: nobody → Robert Dyer (psybers)
Robert Dyer (psybers) wrote :

I think maybe you have 2 Firefox launchers on your system. One in /usr/share/applications/firefox.desktop and a second one, which is what you added to Docky (I do not know the path of that one).

Please tell me the path to your Firefox launcher on your dock. You can find this by looking in GConf at '/apps/docky-2/Docky/Interface/DockPreferences/Dock1/Launchers' which should contain the path to your firefox.desktop. Please post that here.

Also, you can probably fix it by doing the following:

1) remove Firefox from your dock (drag it off, release)
2) launch Firefox from a terminal
3) a Firefox icon should appear on Docky, right click that and choose to Pin it

Then it probably will work fine.

Robert Dyer (psybers) on 2010-04-05
Changed in docky:
status: New → Incomplete
owen.c (owen-c93) wrote :

Sorry to but in, but I'm using minefield and have this problem. I tried all manners of re-adding, pinning and gconf editor but none of them worked. In the end I just went to /usr/share/applications/firefox.desktop and changed the target of the shortcut. Then re-added the icon.

sensory (ivtephx) wrote :

I had this problem until I added the launcher from /usr/share/applications. Pinning the application when started from Terminal or from the launcher that Gnome-Do uses caused this problem in the first place.

Jeremy Jongsma (jeremy-jongsma) wrote :

I have this with almost every app I pin to the dock.

Per suggestions above, I tried the following to pin apps to the dock:

1) Start from app menu or terminal
2) Right-click the dock icon, and pin it to the dock

Starting another instance right away results in proper grouping (no duplication). BUT, as soon as I close all the windows, and then launch another instance (i.e. with gnome-terminal), then a duplicate icon appears on the right, and all new app instances are grouped under it.

Checking in gconf reveals that the items in the dock are correctly pointing to the /usr/share/applications launchers, but this problem persists. This happens even with many single-instance apps (like rhythmbox), although some (like empathy) behave correctly. It's very inconsistent.

Rico Tzschichholz (ricotz) wrote :

@Jesus: Do you still have this issue with the latest ppa version?

tags: added: windowmatcher
Robert Dyer (psybers) wrote :

Marking Invalid as this bug is most likely resolved and no input from the original submitter in 2 months.

Changed in docky:
status: Incomplete → Invalid
Changed in docky:
status: Invalid → New
Yotam Benshalom (benshalom) wrote :

This bug affects me too on ubuntu 10.10. I guess that this is because the .desktop file points at the "firefox" script while the true process running is "firefox-bin" which exists in /usr/lib/firefox-3.6.8/ (outside the path). My version is Docky 2.1.0 bzr docky r1605 ppa.
When I pin a running instance of firefox I have no icon on Docky (just the generic grey blob). I tried to create a custom launcher pointing to firefox-bin, but that doesn't work. I get "/usr/lib/firefox-3.6.8/firefox-bin: error while loading shared libraries: libxul.so: cannot open shared object file: No such file or directory".

Robert Dyer (psybers) on 2010-08-10
Changed in docky:
status: New → Invalid
Robert Dyer (psybers) wrote :

Remove all created launchers, you only need the default one installed with Firefox.

Remove all Firefox launchers from your dock.

Close Firefox.

Run 'firefox' from a terminal, it should show up on your dock now. Right click that and 'pin to dock'.

TheQuickBrownFox (theprash) wrote :

Hi all,

I have discovered a workaround, which works for me:

1. Search for "firefox" in the home directory.
2. Delete any results ending in ".desktop".
3. Create a single launcher if required.

After this, things work as expected. This is a workaround because Docky should not be getting confused by extra launchers that exist, so there is probably a bug in Docky. Though, it is also possible there is a more fundamental problem with gnome launchers.

Robert Dyer (psybers) wrote :

No the problem is there shouldnt be more than one launcher for 'firefox' in your ~/.local/share/applications directory. Once you fixed that Docky worked fine because the assumptions Docky made were met.

Changed in docky:
status: Invalid → Opinion
status: Opinion → New
TheQuickBrownFox (theprash) wrote :

Is there a recommended limit to the number of firefox launchers in ~/.local/share/applications?

I did not manually add the other launchers. They appeared by various means over the years. Why should Docky make the assumption that there is only one launcher for firefox? This behaviour is unexpected. If it is not a valid bug then add this assumption to some documentation.

Robert Dyer (psybers) wrote :

This bug is INVALID but because so many of you insist on messing with the damn status, im moving it to one you cant change.

Changed in docky:
status: New → Won't Fix
TheQuickBrownFox (theprash) wrote :

Ah, at least the status of "Won't Fix" is more honest now. I understand if you don't have the time or inclination to fix this. Any work is appreciated. But stating it is invalid in caps doesn't help explain why.

The result of this bug for me was several weeks of clicking on the Firefox launcher to focus on my current window, only to have a new one open instead, then closing that and clicking on the question mark icon. Only after getting really annoyed, I spent about an hour looking for a solution. And all for not actively maintaining a hidden directory.

I hope you will understand this and leave the bug open to be fixed by someone in the future, perhaps. Otherwise, a proper explanation of why it is invalid would be appreciated, since the solution you have been providing above doesn't appear to work.

Robert Dyer (psybers) wrote :

No, the bug is Invalid. As has already been stated several times above, this is not a bug in Docky but rather a problem with your personal files. If you have more than 1 launcher Docky can (and will!) pick the 'wrong' one! Fix your launchers and the 'problem' goes away.

The solution for me was to do the following.

Remove the already existing Firefox shortcut from Docky.
In Terminal, go into /usr/share/pixmaps

Copy the firefox.png icon to "firefox-3.0.png". (sudo cp firefox.png firefox-3.0.png)
Copy the firefox.png icon to "firefox-3.5.png". (sudo cp firefox.png firefox-3.5.png)
Copy the firefox.png icon to "firefox-3.6.png". (sudo cp firefox.png firefox-3.6.png)

(I don't know which one is actually used. That's why I include all three.)

Then, in terminal, type "firefox" to start the browser, and then in docky, right click the firefox icon and select "pin to dock".

hotani (hotani) wrote :

I fixed this by deleting firefox.desktop from ~/.local/share/applications, launching the firefox I wanted in the dock, then pinning it.

Before, I would launch FF4 beta, and an icon for "Firefox 3.5" would show up in docky. Probably something I created in the past at some point but I was unable to get rid of it.

hotani (hotani) wrote :

The above process worked in ubuntu, but not LMDE, for which I am still looking for a fix.

I don't see how this is not a Docky issue. Anytime I attempt to use a non-standard firefox build, in this case the latest beta, Docky continues to add an additional (and wrong) icon which points to the system default firefox. If I pin the extra icon to the dock, quit Firefox Beta, then click it, the default Firefox opens. This is not an expected behavior.

Robert Dyer (psybers) wrote :

@hotani: The behavior you describe is part of bug 688447. Once you pin the (custom) launcher, it should prefer using that one over the system default.

hotani (hotani) wrote :

So I get this to work finally by copying the .desktop file for the built-in firefox, changing the values in the file, then dragging the new modified firefox.desktop file to docky.

Not user-friendly, intuitive, or any of that, but it works.

Since I'm using LMDE, i noticed Firefox 5 hit debian testing so there's not much point in me using the custom downloads any more. No problem. Docky wants to use the built-in firefox so bad, this should be easy. I remove my launcher from docky, launch the new system default firefox 5 and the icon in docky still has my old "Firefox5" label on it, not the system default "Firefox Web Browser" label.

Deleting my downloaded firefox folder and the accompanying firefox.desktop file from the system results in a generic application icon (still with my old label) when I launch Firefox from the menu or command line. Pinning this to the dock and attempting to launch firefox does nothing (it bounces twice and does not launch the application).

It's the same problem in reverse. I can't get the built-in icon to work with docky now without having two icons. If this is not broken, then we're using a different meaning of the word. Are the icons/launchers cached somewhere? What causes this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers