Error displaying emblems for icons

Reported by PiranhA on 2010-03-08
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Docky
Low
Robert Dyer
docky (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

I'm using the bookmark docklet. When a directory has an emblem set, docky is showing it correctly. If its changed docky needs a restart. But when I unselect the emblem that was previously displayed in docky, the icon is replaced by an error image.
When I again select the emblem the error image is replaced again with the icon for the emblem.

I'm using Docky from the PPA (Docky 2.1.0 bzr docky r1171 ppa) with Ubuntu 9.10.
The attached image shows the error.

PiranhA (ghostmail) wrote :
Robert Dyer (psybers) on 2010-03-08
Changed in docky:
assignee: nobody → Chris S. (cszikszoy)
importance: Undecided → Low
Robert Dyer (psybers) wrote :

For me, just adding the emblem and restarting Docky (to get it to show) gives me both the emblem and the 'error' emblem above it. I dont need to set/unset/reset it.

PiranhA (ghostmail) wrote :

I was able to remove one of the both error images.
The emblem that was previously set, is not available in my current icon set. So I switched to the old one and was able to unset the emblem.
For the download folder the problem stays. I also checked the other icon sets, but the only emblem I have set is available on all icon sets.

Lee Hyde (anubeon) wrote :

I'm experiencing the exact same issue with erroneous emblems decorating my 'Downloads' and 'Documents' folders. I suspect the cause is, as is suggested above, the assignment of an emblem which is non-existent in my current icon theme (elementary-monochrome). The thing is I've iterated through each and every one of my installed icon themes in an effort to identify the errant emblem(s) to no avail. I must have deleted the offending icon theme at some point and since this behaviour is not replicated in nautilus and I'm new to docky2, I never realised there was an issue until now.

Is there any means of removing ALL assigned emblems from any given folder or file icon?

Robert Dyer (psybers) wrote :

What we need to do regarding emblems is, if the file does not exist dont show the emblem (instead of showing the 'missing icon' image instead).

Also I have no idea where the emblem data is stored, so removing it is a bit of a pain... I also have some emblems that no longer exist (ubuntu one for example).

Chris S. (cszikszoy) wrote :

Let me clear up some confusion here. This is how emblems work.

All emblem information is stored in the gvfs database. This metadata is queryable through the standard GLib file information querying techniques. On the command line, this can be achieved by using gvfs-info. The emblems are an entry in the "metadata::" database. To query all of the emblems currently set for a particular file, use:

gvfs-info -a "metadata::emblems" <file>

Note that you can also use a wildcard to query all of the keys in the metadata namespace, simply use "metadata::*"

Via the command line, you are also able to set attributes, using gvfs-set-attribute <file> metadata::some-key "A metadata value"

I agree that it would be a good idea for docky to only display emblems that exist in the current icon theme.

Lee Hyde (anubeon) wrote :

Thank you Chris, that was most insightful!

Having applied your methodology to my two problem folders, ~/Downloads and ~/Documents I get the following output for both:

attributes:
  metadata::emblems: []

Which I assume means that these folders have no emblems assigned to them? If so this is rather perplexing. Although this behaviour is itself somewhat confusing, since the error (?) emblem only appears when no other emblems (from the current icon theme) are applied. Once another extent emblem is assigned to the offending folders the (?) emblem does not appear.

If the behaviour that I am observing were the result of an 'orphaned' emblem assignment I would expect (a) that said 'orphan' emblem would be mentioned in the output of the above command and (b) that it would still appear, as any other emblem would, upon assignment of any additional emblems, possibly taking up a different position to accommodate the additional emblem.

Lee Hyde (anubeon) wrote :

Hmm, actually it appears that the correct output for any folder/file devoid of emblems should be as follows

attributes:

and not

attributes:
   metadata::emblems: []

@Chris.S: I don't suppose you know the exact command to remove any (and/or all) emblems from a given folder/file?

Lee Hyde (anubeon) wrote :

I've figured out how to remove my 'orphaned' emblems with the following command:

gvfs-set-attribute <file> metadata::emblems ""

On the face of it, this command would appear to overwrite any existing emblem metadata with a single blank emblem, as the new output of the aforementioned output is:

attributes:
  metadata::emblems:

rather than:

attributes:

which appears to be the output of any icon with no assigned emblem metadata. In any case this has also solved my issue vis erroneous (?) emblems in docky; they are gone.

Robert Dyer (psybers) wrote :

Fixed in rev 1538.

Changed in docky:
assignee: Chris S. (cszikszoy) → Robert Dyer (psybers)
status: New → Fix Committed
milestone: none → 2.0.5
Changed in docky:
status: Fix Committed → Fix Released
summary: - Error displaying emblems for icons
+ debdiff which fixes this is attached to bug #579049
summary: - debdiff which fixes this is attached to bug #579049
+ Error displaying emblems for icons
Rico Tzschichholz (ricotz) wrote :

debdiff which fixes this is attached to bug #579049

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package docky - 2.0.5-1

---------------
docky (2.0.5-1) unstable; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that don't have a...

Read more...

Changed in docky (Ubuntu):
status: New → Fix Released

Accepted docky into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in docky (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package docky - 2.0.5-0ubuntu1

---------------
docky (2.0.5-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that do...

Read more...

Changed in docky (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers