wrong icon displayed for mint update manager

Reported by bronto on 2010-02-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Docky
Low
Rico Tzschichholz
docky (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

synaptic is displayed with two icons, one for synaptic and another for docky (os is linux mint8 main (gnome), which is based on karmic).

bronto (b-kravca) wrote :
bronto (b-kravca) wrote :

p.s. actually the app in question is 'mint update manager', the icon is a lock.

Robert Dyer (psybers) on 2010-02-03
Changed in docky:
importance: Undecided → Low
assignee: nobody → Chris S. (cszikszoy)
Robert Dyer (psybers) on 2010-02-03
summary: - wrong icon displayed (actually two icons instead of just one)
+ wrong icon displayed for mint update manager
bronto (b-kravca) wrote :

similar problem(s):
1. icon for handbrake not shown (i presume thats because its not in the current gnome theme?)
2. some sort of 'default' theme is sometimes shown for a folder icon in 'recent documents' docklet

Chris S. (cszikszoy) wrote :

is this still a problem as of rev 1329?

tags: added: windowmatcher
bronto (b-kravca) wrote :

handbrake is fine, folders are fine, update manager NOT fine, still the firewall symbol.

Robert Dyer (psybers) wrote :

We need the .desktop file for the update manager as well as the output of 'ps -ef | grep <update>' where '<update>' is the name of the executable.

Changed in docky:
status: New → Incomplete
bronto (b-kravca) wrote :

My noobiness will prevent me from doing this actions my lordship, so some additional info is needed or should i drop into freenode/#docky and ask politely there?

bronto (b-kravca) wrote :
Download full text (3.4 KiB)

 /usr/share/applications $ cat ./mintDesktop.desktop

------------------------------------------------------------------------

[Desktop Entry]
Name=Desktop Configuration Tool
Name[csb]=Desktop Configuration Tool
Name[fr]=Desktop Configuration Tool
Name[nn]=Desktop Configuration Tool
Name[cs]=Desktop Configuration Tool
Name[pt]=Desktop Configuration Tool
Name[fo]=Desktop Configuration Tool
Name[nb]=Desktop Configuration Tool
Name[ar]=Desktop Configuration Tool
Name[ro]=Desktop Configuration Tool
Name[ast]=Desktop Configuration Tool
Name[gl]=Desktop Configuration Tool
Name[ja]=Desktop Configuration Tool
Name[he]=Desktop Configuration Tool
Name[sr]=Desktop Configuration Tool
Name[pl]=Desktop Configuration Tool
Name[lt]=Desktop Configuration Tool
Name[ru]=Desktop Configuration Tool
Name[hu]=Desktop Configuration Tool
Name[fi]=Desktop Configuration Tool
Name[de]=Desktop Configuration Tool
Name[el]=Desktop Configuration Tool
Name[zh_CN]=Desktop Configuration Tool
Name[en_GB]=Desktop Configuration Tool
Name[am]=Desktop Configuration Tool
Name[sl]=Desktop Configuration Tool
Name[es]=Desktop Configuration Tool
Name[tr]=Desktop Configuration Tool
Name[bg]=Desktop Configuration Tool
Name[ko]=Desktop Configuration Tool
Name[mr]=Desktop Configuration Tool
Name[nl]=Desktop Configuration Tool
Name[et]=Desktop Configuration Tool
Name[zh_TW]=Desktop Configuration Tool
Name[sk]=Desktop Configuration Tool
Name[pt_BR]=Desktop Configuration Tool
Name[is]=Desktop Configuration Tool
Name[sv]=Desktop Configuration Tool
Name[hi]=Desktop Configuration Tool
Name[sq]=Desktop Configuration Tool
Name[it]=Desktop Configuration Tool
Name[hr]=Desktop Configuration Tool
Name[uk]=Desktop Configuration Tool
Name[da]=Desktop Configuration Tool
Comment=Fine-tune Gnome settings
Comment[csb]=Fine-tune Gnome settings
Comment[fr]=Fine-tune Gnome settings
Comment[nn]=Fine-tune Gnome settings
Comment[cs]=Fine-tune Gnome settings
Comment[pt]=Fine-tune Gnome settings
Comment[fo]=Fine-tune Gnome settings
Comment[nb]=Fine-tune Gnome settings
Comment[ar]=Fine-tune Gnome settings
Comment[ro]=Fine-tune Gnome settings
Comment[ast]=Fine-tune Gnome settings
Comment[gl]=Fine-tune Gnome settings
Comment[ja]=Fine-tune Gnome settings
Comment[he]=Fine-tune Gnome settings
Comment[sr]=Fine-tune Gnome settings
Comment[pl]=Fine-tune Gnome settings
Comment[lt]=Fine-tune Gnome settings
Comment[ru]=Fine-tune Gnome settings
Comment[hu]=Fine-tune Gnome settings
Comment[fi]=Fine-tune Gnome settings
Comment[de]=Fine-tune Gnome settings
Comment[el]=Fine-tune Gnome settings
Comment[zh_CN]=Fine-tune Gnome settings
Comment[en_GB]=Fine-tune Gnome settings
Comment[am]=Fine-tune Gnome settings
Comment[sl]=Fine-tune Gnome settings
Comment[es]=Fine-tune Gnome settings
Comment[tr]=Fine-tune Gnome settings
Comment[bg]=Fine-tune Gnome settings
Comment[ko]=Fine-tune Gnome settings
Comment[mr]=Fine-tune Gnome settings
Comment[nl]=Fine-tune Gnome settings
Comment[et]=Fine-tune Gnome settings
Comment[zh_TW]=Fine-tune Gnome settings
Comment[sk]=Fine-tune Gnome settings
Comment[pt_BR]=Fine-tune Gnome settings
Comment[is]=Fine-tune Gnome settings
Comment[sv]=Fine-tune Gnome settings
Comment[hi]=Fine-tune Gnome settings
Comment[s...

Read more...

bronto (b-kravca) wrote :

ps -ef | grep mint

------------------------------------------------------------------------

user 2128 1 0 09:42 ? 00:00:01 python /usr/lib/linuxmint/mintMenu/mintMenu.py --oaf-activate-iid=OAFIID:GNOME_mintMenu_Factory --oaf-ior-fd=18
user 2511 1 0 10:23 ? 00:00:00 gksudo --message Please enter your password to start mintUpdate /usr/lib/linuxmint/mintUpdate/mintUpdate.py show 2146
root 2512 2511 0 10:23 ? 00:00:00 python /usr/lib/linuxmint/mintUpdate/mintUpdate.py show 2146
user 2909 2577 0 10:48 pts/0 00:00:00 grep --colour=auto mint

Rico Tzschichholz (ricotz) wrote :

@bronto: Is this fixed for you with bzr1404+?

Changed in docky:
milestone: none → 2.0.5
bronto (b-kravca) wrote :

@Rico: yes, seems to be fixed already in r1382.

Robert Dyer (psybers) on 2010-06-08
Changed in docky:
status: Incomplete → Fix Committed
assignee: Chris S. (cszikszoy) → Rico Tzschichholz (ricotz)
Changed in docky:
status: Fix Committed → Fix Released
summary: - wrong icon displayed for mint update manager
+ debdiff which fixes this is attached to bug #579049
summary: - debdiff which fixes this is attached to bug #579049
+ wrong icon displayed for mint update manager
Rico Tzschichholz (ricotz) wrote :

debdiff which fixes this is attached to bug #579049

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package docky - 2.0.5-1

---------------
docky (2.0.5-1) unstable; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that don't have a...

Read more...

Changed in docky (Ubuntu):
status: New → Fix Released

Accepted docky into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in docky (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package docky - 2.0.5-0ubuntu1

---------------
docky (2.0.5-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that do...

Read more...

Changed in docky (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers