Docky is underneath all windows

Bug #498995 reported by Rovanion on 2009-12-21
132
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Docky
Low
Robert Dyer

Bug Description

In the latest trunk build of docky it seems like Docky always is obscured by other windows, always underneath them.
Though the tooltips are shown and the docky responds to mousover-actions mouseclicks are placed on the window that is above docky, not too much of a surprise maybe.

[Info 11:24:03.973] Docky version: bzr docky r960
[Info 11:24:03.986] Kernel version: 2.6.31.14
[Info 11:24:03.988] CLR version: 2.0.50727.1433
[Info 11:24:04.278] [DockServices] Dock services initialized.
[Info 11:24:04.465] Setting theme: Air
[Info 11:24:04.892] [PluginManager] Loaded "Clock".
[Info 11:24:04.901] [PluginManager] Loaded "Weather".
[Info 11:24:05.635] [AbstractWeatherSource] Weather Underground: Reloading weather data

description: updated
Chris S. (cszikszoy) wrote :

I'm not quite sure I understand what you mean. Does this happen for all apps, or just fullscreen apps? What autohide setting are you using? And are you saying that docky _stays_ underneath all windows, even when you move your mouse to the edge of the screen?

Changed in docky:
status: New → Incomplete
Robert Dyer (psybers) on 2009-12-21
Changed in docky:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Low
Rovanion (rovanion-luckey) wrote :

Chris S.
You are absolutely correct in your assumptions there. It happens for all apps, not only the fullscreenapps. I tested this using both two settings where the dock stays up even though it obscures windows, but in this state rather is obscured by windows. It stayed underneath all windows even tough I moved my mouse to the edge of the screen pulling docky onto the screen.

Arutha (devplace) wrote :

I'm not sure how to reproduce this bug but it happens now and then.

I've set the dock to autohide. It always works correctly but once in a while the dock is not able to be shown above all the other windows on `autoshow' by mousehovering over the edge. The labels that normally are shown on mouseover are shown topmost. Just the dock is not shown. Also, clicking the invisible icons does nothing. So focus is definitely on the current shown window.

When only half of the dock is shown (i.e., half of it is covered by a window), the part of the dock visible is clickable, the half that is obscured is not.

Problem can be resolved by restarting docky.

Docky R1026
Ubuntu Karmic Koala (9.10) x64
Latest stable Compiz Fusion with cube virtual desktop switcher, expo, scale, shift switcher, grid, and widget layer enabled (in case it is compiz which steals focus or changes focus related matters)

Pavel (rustynail) wrote :

I don't know if i'm experiencing the same bug or not, BUT:
Docky IS drawn over windows, but it doesn't seem to get focus... All mouse clicks go through to the window bellow Docky...
Same happens with the preferences window. :-\
Restarting doesn't help...

I'm running the latest build of docky on Karmic x64.

Pavel (rustynail) wrote :

btw, I just noticed the same problem with gnome-panel, which I also have on autohide, so it seems this has something to do more with mah compiz than with docky...

Robert Dyer (psybers) wrote :

@Rovanion/Arutha: has this happened lately?

I suspect it was an issue with the window manager. Rovanion, do you use Compiz?

Rovanion (rovanion-luckey) wrote :

I have not been using my ATi HD4850 fglrx powered computer with docky for a long while since the framerate is horrible when it comes to animating the dock. This bug does not appear on my Radeon 9800 mesa powered computer, but nor did it ever appear on that computer as far as I remember.

So I have no new data on this bug, sorry.

Robert Dyer (psybers) wrote :

Ok this just happened to me. Compiz crashed and Metacity automatically loaded (non-composited). I replaced with Compiz and noticed both the panel and Docky were 'under' all windows and would not pop up. Clicking on them once brought them to the top, and they stayed there!

Dominik Mayer (dominik-mayer) wrote :

The problem also appears on XMonad. Quick Question: Why is the importance of this bug low? What's the use of a panel that can't be seen?

Robert Dyer (psybers) wrote :

It is low because for the most part, this only randomly affects a small number of people. Also (at least for me) it is easily fixed by simply left clicking on the dock once.

Dominik Mayer (dominik-mayer) wrote :

In my case Docky is amost all of the time below the window (if set to one of the hide options) and left clicking does not help.

Robert Dyer (psybers) wrote :

@Dominik: your case is most likely a bug (or perhaps a missing feature) in XMonad. Sounds like XMonad is not honoring the request to be 'always on top' (aka, 'above').

The 'general' case is most likely a bug in Compiz and/or Metacity.

Dominik Mayer (dominik-mayer) wrote :

I doubt it's an XMonad issue. If it was, Docky would always be below, not just 95 percent of the time. And the tooltips wouldn't be shown either. The GNOME Do Docky has the same problem and I set XMonad to not completely ignore GNOME Do, so it's not handled by XMonad.

Dominik Mayer (dominik-mayer) wrote :

The status is still set to "incomplete". Is there anything I can do to help triaging the bug? I'm using "Docky 2.1.0 bzr trunk r1597" now.

Changed in docky:
status: Incomplete → Fix Committed
Robert Dyer (psybers) wrote :

Dont change the bug status.

Changed in docky:
status: Fix Committed → New
Nicolas Krzywinski (nsk7even) wrote :

Hello,

I encountered this bug also, but exactly as Pavel described it (Docky and Gnome-Do are on top, but all clicks pass through to the underlying app, with one exception: minimising all apps works - then Docky/Gnome-Do are receiving the clicks, so they don't go to the desktop then..).

Furthermore and really interesting: my bottom gnome panel is configured to auto-hide but additional those "go away" arrows are activated. Somewhen today I decided to toggle the gnome-panel to the right with this arrow ... and now I could not get it back since the arrow for the original gnome panel does pass the clicks through to the underlying app as well!
The top panel is not configured to auto-hide and it responded as usual.

This tip here solved it for me, at least currently: http://ubuntuforums.org/showthread.php?t=1274398

To sum up: Docky, Gnome-Do and gnome-panel on auto-hide behaved the same, always-on-top compiz rule solved it for now

hackel (hackel) wrote :

I'm still getting this issue every single day with docky 2.0.8~bzr1397-0ubuntu1~10.10~dockycore1. This is a very serious usability issue and the importance should be set to "high". I realize it is apparently not affecting everyone, but it does affect a sizeable number of users, so let's figure out what's going on! I'm using Compiz, and I'm certain that is playing a role in this. I've tried setting Docky to "always on top" with Compiz window matching plugin, but it makes no difference.

I would like to ask the developer what I can do to further debug this issue when it happens, since I have been unsuccessful in identifying any trigger which causes the change. Docky is a surprisingly useful and responsive application, but as Dominik said, "What's the use of a panel that can't be seen?"

Robert Dyer (psybers) wrote :

I only see 5 people affected by this bug commenting about it, and 10 total. Thus it does not seem to affect many users.

Additionally, some users report an easy fix (for Compiz) or report that it does not happen all the time (and thus a restart would fix it).

So far no user has given us information that can help us track the problem and the devs are not experiencing the problem (note: the devs use Compiz).

My guess is any Compiz user with this problem has done something (loaded a Compiz plugin, set a weird setting, who knows!) that broke it. My only hint for those users is to disable all Compiz plugins and reset all Compiz settings to default, and go from there.

Dominik Mayer (dominik-mayer) wrote :

What information do you want? I do not use Compiz and restarting Docky every five minutes is not an option.

Robert Dyer (psybers) wrote :

You are the only person on XMonad, so I am going to assume it is a bug with that until I hear someone else claim otherwise.

Rovanion (rovanion-luckey) wrote :

It is not a bug in XMonad since I experienced the bug using Metacity coupled with Compiz.

Dominik Mayer (dominik-mayer) wrote :

It's also not a bug because it even happens when XMonad does not handle Docky.

Nicolas Krzywinski (nsk7even) wrote :

Another detail that hints to this problem not being a bug within Docky:
Today I first called seahorse to create a GnuPG key and I noticed that this key generating dialog was not clickable as long as other windows were below it. After that, Docky let clicks go through it as it was before the workaround I wrote above.

I don't know why this problem re-arises today, nor why and how it is associated with this seahorse dialog...

The only supplemental interesting thing I noticed:
I placed the gnome panel on my second monitor in the meantime - there it was clickable even with other windows below it. But when pressing the side arrow this panel swaps to the primary monitor then (which is kind of weird in dual monitor setup because it is not placed correctly on the bottom then but this is a different point); on the primary monitor the gnome panel was not clickable as well.

Maybe no one understands what I am talking about and I don't understand the relationship between those occurences, but maybe this is kind of help to s. o.

Robert Dyer (psybers) wrote :

Rev 1753 might help this. Let me know one way or the other.

Changed in docky:
assignee: Jason Smith (jassmith) → Robert Dyer (psybers)
status: New → Fix Committed
Robert Dyer (psybers) on 2011-01-07
Changed in docky:
milestone: none → 2.0.11
Rico Tzschichholz (ricotz) wrote :

@Robert: please look at bzr1324 and bzr1332

Robert Dyer (psybers) wrote :

That was 8 months ago! And I dont use Metacity. :-p

Feel free to revert etc etc, but I am curious if this fixes the issue in XMonad...

Changed in docky:
status: Fix Committed → Confirmed
milestone: 2.0.11 → none
Dominik Mayer (dominik-mayer) wrote :

I installed 2.1.0 bzr docky r1762 but it doesn't even start up so I can't check if the XMonad problems are solved. I'll try again.

Yuriy Voziy (yuretsz) wrote :

I'm using docky for a year on my Laptop, Netbook an PC. I need to restart docky few times a day to make it shown on top of other windows. This is really annoying.

khairie (wmkhairie) wrote :

It seems this is happening to me when I move my mouse into VirtualBox machine, and back to my Ubuntu host pc again. Any workaround for this?

marcvangend (info-marcvangend) wrote :

I'm still encountering this error now and then. Usually it just works, but sometimes Docky suddenly disappears behind other windows. Minimizing all windows and bringing them back again turns out to be a workaround. Like khairie I'm using VirtualBox, however I'm not certain if that is the cause of the problem.

Nishant George Agrwal (niagr) wrote :

I am also experiencing this bug in updated oneiric from stable ppa. I'm using compiz, and this bug also appears when using dockbarx. however, when using dockbarx, the icons also pop up on mouseover. but the body of the dock doesn't. when the window is minimized, the dock shows fragments of the window that was minimized instead of the body, with the icons rendered over it.
just thought the info might help

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers