docky freezes when changing resolution/screen

Reported by Commander on 2009-12-10
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Docky
High
Jason Smith

Bug Description

Hi,

The problem is that docky sometimes freezes. Sometimes at startup, and coming up from hibernation on my laptop. And almost all the time when changing resolution and or screen.

Screenshot = http://bayimg.com/image/bagfhaacp.jpg

Also no errors from debug as you see.

Ubuntu 9.10 Karmic, latest docky 817, HP 6510b laptop.

Best Regards
Commander

Commander (artur-olech) on 2009-12-10
tags: added: freezing
tags: added: freeze
removed: freezing

The startup freezes are known. Generally caused by having weather and/or gmail plugins enabled. This freeze happens (as best we can tell) about 5% of the time.

I do not get the other freezes you mention. What video card? It might be related to multi-mon, most of the devs do not really test that feature due to lack of monitors.

summary: - "docky freezes" "when changing resolution/screen" "on startup" "starting
- from hibernation"
+ docky freezes when changing resolution/screen, on startup, and re-
+ starting from hibernation
Changed in docky:
importance: Undecided → Low
status: New → Incomplete
assignee: nobody → Jason Smith (jassmith)
Commander (artur-olech) wrote :

Intel GM 965 Chipset. The freezing during startup have happend like 3 times last 2 days. The resolution freezing happens 90% of the time.

Have both of the mentioned plugins enabled.

Thiago Bellini (hackedbellini) wrote :

I think the freezing on startup never happened, but, the freezing when changing resolution happens a lot!
Happens more when changing from a low value to a high value than hight to low
I'm attaching an SS of the problem!

Thiago Bellini (hackedbellini) wrote :

Ah, my card is a: Intel Graphics Media Accelerator X4500HD

Joel Auterson (joel-auterson) wrote :

Happens around 90% when Docky starts up. Only changed resolution once, and it didn't freeze then.

GeForce 220GT 1GB

Yotam Benshalom (benshalom) wrote :

I suffer from the weather-freeze bug, and it happens 90% of the times upon login. The exact moment of freeze is when the wireless connection is made. I use the nvidia 195 drivers. Is there a specific bug report dealing with that freeze?

Robert Dyer (psybers) wrote :

Ok this bug report will focus on the resolution change freezes, which seem to be affecting Intel GPUs.

@Joel/Yotam: the startup bug is (afaik) not reported, but the devs are *well* aware of it. I promise you we restart Docky way more often than you do. ;-)

Robert Dyer (psybers) wrote :

This bug seems to affect more than just Intel GPUs.

summary: - docky freezes when changing resolution/screen, on startup, and re-
- starting from hibernation
+ docky freezes when changing resolution/screen
Robert Dyer (psybers) wrote :

Ok there are multiple bugs that are duplicates of this. You can see this problem in *many* ways.

The problem is in the MaxIconSize calculation, which attempts to change the IconSize on the dock to fit all your icons into the space available. This apparently can freeze.

Changed in docky:
importance: Low → High
status: Incomplete → Triaged
Robert Dyer (psybers) wrote :

Fixed rev 1236.

Changed in docky:
status: Triaged → Fix Committed
Karl Lattimer (karl-qdh) wrote :

If this is fixed in 1236 why is it still doing it with 1256?

Seriously this is taking the piss now, docky has been completely unusable for too long... i'm now removing it

Robert Dyer (psybers) wrote :

@Karl: Good. I don't want users like you anyway. Bugs exist *in every project*. We donate our time and effort to maintain this project. If that is not good enough for you, then go away.

Daniel Fore (danrabbit) wrote :

Karl,

I'm going to have to agree with Robert. It's ridiculous to think that every bug can be solved immediately. Robert has been on a bug smashing rampage and has squashed TONS of bugs. I'm sorry that its affecting you more than others, but if Docky isn't working out for you and you don't want to wait then it would be best to find another solution.

Michael Merline (merline) wrote :

I haven't had a freeze in some time, and I used to have them daily. So things are definitely moving in the right direction!

M

Karl Lattimer (karl-qdh) wrote :

My point here is that closing a bug and saying its fixed when it isn't doesn't help anyone. Obviously not every bug can be solved immediately, but I've had this bug since February, I'm not the only one who has it, and closing a bug as fixed when this is the case is just plain silly.

@Robert, getting angry at your users because they've been trying to use their computer for a few hours with every 2 seconds *YOUR* software locking up and preventing them from doing that isn't exactly good public relations.

Seif Sallam (seif.sallam) wrote :

@Karl maybe when they first marked this bug as fixed it was. Then during development something triggered this bug again.

Robert Dyer (psybers) wrote :

First off, like Seif mentioned bugs can regress. We do not mark any bug as Fix Committed/Released unless we have tested it and verified that it is indeed fixed. There may be other ways to trigger the bug (thus it is actually more than one bug with the same symptoms) also, meaning we might fix it and it 'still exists'.

Second, you said yourself you aren't a user "im now removing it" and as such I will treat you how I want. Generally I am a very nice person, but if I feel offended I will not sugar coat it.

Third, why are you changing screen resolutions every 2 seconds? That just seems absurd. I think you have bigger issues than the dock lagging if that is your case....

Fourth, I suspect (from your comment about 'every 2 seconds') that you are not actually experiencing *THIS* bug, which is only triggered when you resize the screen and force Docky to recompute its max icon size. I actually had a user in IRC with me that could reproduce this bug consistently and he tested my fix out and verified it was fixed prior to my pushing it to trunk.

So please get your facts straight before you start preaching to me about how to handle this project.

Karl Lattimer (karl-qdh) wrote :

@Seif, doubtful, I've been updating with every possible release as I had made docky my main panel without any other gnome-panel... At times it has been marginally better, but never fixed.

Karl Lattimer (karl-qdh) wrote :

Hang on a second, "preaching" ... I'm not changing screen resolution every 2 seconds...

When I added to this bug it was about freezing, now its changed. I agree it's probably not *this* bug - after catching up on comments I'd have to agree.

You can't blame me for trying to join a bug rather than file a new one however, and when I joined this bug it did seem to be the same issue...

However, having said all that, being disrespectful to users is never a good option Daniels reply was far more respectful and acceptable to me.

Robert Dyer (psybers) wrote :

I suppose its ok for our users to disrespect the developers though, huh?

And once more for the record, as far as I know (based on testing done by a user affected by this bug) *this bug* is fixed.

If you have other bugs feel free to either find the real bug report or lacking one that matches your situation, file one. We can not read your mind. We do not know about bugs until they are filed. So far you have only commented on a bug that we believe is fixed (and I still believe that).

I will go find other, reported bugs to work on and I guess your specific problem will not get solved.

Changed in docky:
status: Fix Committed → Fix Released
Changed in docky:
milestone: none → 2.0.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers