Opening Tucan application from the dock creates a new icon on it

Bug #480867 reported by Ibai Oihanguren Sala on 2009-11-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Docky
Low
Chris S.

Bug Description

I've got Tucan Download Manager installed on my Ubuntu, and a launcher on Docky. When I click the icon of Tucan, instead of opening the application and showing the small light under the Tucan icon, another icon (a gray X) appears on the Docky, named "Tucan Manager - Version 0.3.8 alpha".
This happened in Gnome Do with Wine applications... but Tucan worked well.
I guess it will happen with more applications too.

I use:

Ubuntu 9.10
Docky version 2.0.0 Alpha 1
Intel 82G33/G31 video card
Gnome 2.28.1

Robert Dyer (psybers) on 2009-11-11
Changed in docky:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Low
Wadelius (wadelius) wrote :

This affects me to. When I run wine applications, for example Spotify I get two icons, one of them being a cross. This is a partial regression from Gnome Do, since it used to be possible to attach an icon to a wine app. The way I used to do it is by placing an icon in /usr/icons/ with the same name as the process, in this case spotify.svg. Gnome Do-Docky then used the icon instead of the cross. If you put the mouse pointer over the cross it says "Wine Windows Program Loader", it used to just say "Spotify".

Wadelius (wadelius) wrote :

Forgot; I'm using:
- Ubuntu 9.10
- Docky 2.0.0 Alpha
- Gnome 2.28.1

Chris S. (cszikszoy) wrote :

I must have fixed this somewhere along the lines with my changes to the window matcher. Adding tucan to the dock and opening a new instance works as expected for me.

Changed in docky:
assignee: Jason Smith (jassmith) → Chris S. (cszikszoy)
status: New → Fix Committed

I can confirm that now it is fixed for me. Thanks!

Wadelius (wadelius) wrote :

I confirm that it works for Spotify as well. Now I can add Spotify as a launcher, that is a first, it didn't work with gnome-do.

Keep up the good work!

Robert Dyer (psybers) on 2010-02-27
Changed in docky:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers