dockbarx fails to recognize windows moved to another workspace

Bug #854551 reported by markusj
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DockbarX
Undecided
Unassigned

Bug Description

This bug affects DockbarX 0.44-0~ppa1 as well as DockbarX 0.47-1~webupd8~maverick. Using Ubuntu maverick with standard desktop and DockbarX placed into a gnome-panel.

Moving a Window to another workspace (either by a Keycombo or using the window context menu) leaves this windows entry in DockbarXs window list until the workspace has been changed. The configuration option to ignore windows on other workspaces is selected!

This bug wasn't there forever, it appeared a few versions ago, sadly i can't tell exactly by which version it had been introduced.

Revision history for this message
Matias Särs (msevens) wrote :

Thanks for reporting. To be honest I don't think there ever was any code for this. I can't remember writing it and when lookingt older revisions (250) I can't see anything there (not that I searched for very long).

Well now it's fixed anyway.

Changed in dockbar:
status: New → Fix Committed
Revision history for this message
markusj (markusj) wrote : Re: [Bug 854551] Re: dockbarx fails to recognize windows moved to another workspace

It looks like if this bug isn't fixed yet, at least in DockbarX
0.48-1~webupd8~maverick. The group icon indicating how much windows are
open (btw. why does it only count up to four?) is updated if a window
has been moved to another workspace, but the list itself contains still
the moved window. However, if i tell DBX to close the group, the moved
window is not affected.

One further question: If this function has not been implemented before,
why is there a configuration option to ignore windows at other
workspaces (first one at the extended tab)? Sounds like a lost/forgotten
feature, doesn't it?

Matias Särs (msevens)
Changed in dockbar:
status: Fix Committed → Confirmed
Matias Särs (msevens)
Changed in dockbar:
status: Confirmed → Fix Committed
Matias Särs (msevens)
Changed in dockbar:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers