'Needs Attention' Effects are not eye-catching

Bug #692152 reported by Nick on 2010-12-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DockbarX
Undecided
Unassigned

Bug Description

The only 'Needs Attention Effect' that works for me is the 'blinking' one. Even then it blinks only slightly brighter than the icon already is, so it's really easy not to notice something needing attention. Contacts on Pidgin think I'm ignoring them because I don't see when they've replied.

As for the other options: 'Compiz Water' and 'Static' both do nothing in my case. Having used an older version of DockBarX I recall Compiz Water working but I didn't find it useful. It just makes sense to me to have a reasonably bright and obvious blinking action. Blinking in the OS's 'selected item' colour would make sense. Or at least have a greater variation between the original colour or brightness and the blinking one.

I'm using the Unity_v theme on Ubuntu 10.10. I've tried at least 2-3 other themes and the needs attention effect had no affect also (besides the standard blinking) on both vertical and horiztonal panels.

Matias Särs (msevens) wrote :

The theme completely sets how the effect looks (except for compiz water). Static just changes to a "attention" appearance while blinking switches between an "attention" appearance and the "normal" appearance. I made the original static look as the icon with a red background and blink as a bit brighter than normal. Since then most theme makers has simply copied these looks.

This isn't the first complaint I've got about this. As a result, the new default theme (DBX) has a much more aggressive blink effect with a blinking red background. Perhaps I should go out with a message to theme makers to update their themes with more aggressive blinking effects as well?

arzali (wyfer) wrote :

I just updated the unite themes and added a perhaps more "eye catching" blink effect :) http://bigrza.deviantart.com/art/DBX-big-dock-pack-190103698

Nick (soapduk) wrote :

Thanks for your responses. Matias, I notice that on this theme (unite_v) the attention colour is set to red, but it seems to have no effect on the actual program launcher icon. Not sure why that is. Yeah it is probably worth while sending a message to the theme makers about the lack of an eye-catching blink. :)

Arzali, those icons look good. It says they're for AWN but they work on DBX too do they? I tried installing the faenza pack a few days ago for DBX and didn't manage to get it working (but that's another issue).

I'm guessing the theme updates would come along on the next update for users of the ppa repo.

Matias Särs (msevens) on 2010-12-22
Changed in dockbar:
status: New → Confirmed
Matias Särs (msevens) on 2014-04-25
Changed in dockbar:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers