Drag-and-drop reordering final position isn't as expected

Bug #619937 reported by fubarbundy
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DockbarX
High
Unassigned

Bug Description

[on a horizontal panel] When dropping an icon to re-order, the expected new position would be the gap nearest the mouse cursor. However, it is always the gap to the right of the mouse cursor.

To reproduce: Drag an icon and move the cursor a fraction to the right of the leftmost edge of another launcher.

Expected: dragged icon goes to the left of the other launcher.

Actual: dragged icon goes to the right of the other launcher.

Additional bug caused by this: Can't drag a launcher all the way to the left of DockbarX.

Matias Särs (msevens)
Changed in dockbar:
importance: Undecided → Wishlist
Revision history for this message
Tom Metro (tmetro+ubuntu) wrote :

I see this too with 0.39.7 on Ubuntu 9.10.

Matias Särs (msevens)
Changed in dockbar:
status: New → Confirmed
importance: Wishlist → High
Matias Särs (msevens)
Changed in dockbar:
status: Confirmed → Fix Committed
Matias Särs (msevens)
Changed in dockbar:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers