Activity log for bug #424629

Date Who What changed Old value New value Message
2009-09-04 23:52:53 Alex K bug added bug
2009-09-04 23:53:49 Alex K description DockbarX should to handle invalid themes better. Most importantly, the Properties dialogue should still open. Currently, if an invalid theme exists inside ~/.dockbar/themes (and, I suppose, /usr/share/dockbar/themes), Properties opens as a tiny (~15x20px), unusable window with nothing in it. If a theme is edited while active, (theme development is the only place where this happens, I think), then it becomes even worse. Sometimes the icons are all replaced with a single vertical white line, which can only be fixed by changing the theme.s extension to .tar.gz.bac (or something similar), removing dockbar from the panel, and adding it again. This makes pushing the limits of DockbarX's theme engine tricky. Unfortunately (and I'm working on this), I'm not a programmer. However, I think part of the problem is the way Dockbar checks the themes when you open Properties. I think it is good that the theme engine is fairly strict. That's good. However, it would be much better if Dockbar could * Pop up an error message? * Maybe give an option to revert the theme to it's last valid state (if possible)? * Automatically switch to a valid theme? * Gray out the invalid theme in the dropdown? Also, having typed this all out, it sounds like a lot of work, but the main thing is how the Properties dialogue crashes when an invalid theme is present. DockbarX should to handle invalid themes better. Most importantly, the Properties dialogue should still open. Currently, if an invalid theme exists inside ~/.dockbar/themes (and, I suppose, /usr/share/dockbar/themes), Properties opens as a tiny (~15x20px), unusable window with nothing in it. If a theme is edited while active, (theme development is the only place where this happens, I think), then it becomes even worse. Sometimes the icons are all replaced with a single vertical white line, which can only be fixed by changing the theme.s extension to .tar.gz.bac (or something similar), removing dockbar from the panel, and adding it again. This makes pushing the limits of DockbarX's theme engine tricky. Unfortunately (and I'm working on this), I'm not a programmer. However, I think part of the problem is the way Dockbar checks the themes when you open Properties. I think it is good that the theme engine is fairly strict. That's good. However, it would be much better if Dockbar could + Pop up an error message? + Maybe give an option to revert the theme to it's last valid state (if possible)? + Automatically switch to a valid theme? + Gray out the invalid theme in the dropdown? Also, having typed this all out, it sounds like a lot of work, but the main thing is how the Properties dialogue crashes when an invalid theme is present.
2009-09-05 06:47:16 Matias Särs dockbar: status New Confirmed
2009-09-05 06:47:19 Matias Särs dockbar: importance Undecided Medium
2009-09-21 19:58:16 Matias Särs dockbar: status Confirmed Fix Committed
2009-09-25 19:54:42 Matias Särs dockbar: status Fix Committed Fix Released