Do

Gnome do Won't auto start in Ubuntu 9.10. Gives error when run in the terminal

Bug #485583 reported by Glen on 2009-11-20
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Do
Undecided
Unassigned

Bug Description

Gnome Do won't auto start in Ubuntu 9.10

When I try to run it from the terminal I get the following:

(Do:6121): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.

Robert Dyer (psybers) wrote :

Please run from a terminal with '--debug' flag and post the output here.

That message you posted here is harmless, we all get that. ;-)

Changed in do:
status: New → Incomplete
xavs (olivao) wrote :
Download full text (7.5 KiB)

~$ gnome-do --debug

[Debug 13:10:31.224] [SystemService] Using org.freedesktop.DeviceKit.Power for battery information
[Info 13:10:31.234] [Services] Successfully located service of type ILogService.
[Info 13:10:31.234] [Services] Successfully located service of type IPreferencesService.
[Info 13:10:31.235] [Services] Successfully located service of type ISecurePreferencesService.
[Info 13:10:31.244] [Services] Successfully located service of type INotificationsService.
[Debug 13:10:31.249] [InterfaceManager] "Glass" interface was loaded
[Info 13:10:31.250] [Services] Successfully located service of type ILogService.
[Debug 13:10:31.250] [InterfaceManager] "Docky" interface was loaded
[Debug 13:10:31.251] [InterfaceManager] "Mini" interface was loaded
[Debug 13:10:31.252] [InterfaceManager] "Classic" interface was loaded
[Debug 13:10:31.253] [InterfaceManager] "Nouveau" interface was loaded
[Debug 13:10:31.259] [PluginManager] Loaded "NotesItemSource" from plugin.
[Info 13:10:31.285] [Services] Successfully located service of type IPreferencesService.
[Info 13:10:31.285] [Services] Successfully located service of type ISecurePreferencesService.
[Info 13:10:31.293] [Services] Successfully located service of type ICoreService.
[Info 13:10:31.295] [Services] Successfully located service of type INetworkService.
[Debug 13:10:31.302] [PluginManager] Loaded "WeatherItemSource" from plugin.
[Info 13:10:31.304] [Services] Successfully located service of type AbstractApplicationService.
[Debug 13:10:31.305] [PluginManager] Loaded "InternalItemSource" from plugin.
[Debug 13:10:31.305] [PluginManager] Loaded "ItemSourceItemSource" from plugin.
[Debug 13:10:31.307] [PluginManager] Loaded "PlacesItemSource" from plugin.
[Debug 13:10:31.308] [PluginManager] Loaded "SessionCommandsItemSource" from plugin.
[Debug 13:10:31.309] [PluginManager] Loaded "ProfileItemSource" from plugin.
[Debug 13:10:31.310] [PluginManager] Loaded "ApplicationItemSource" from plugin.
[Debug 13:10:31.311] [PluginManager] Loaded "GNOMESpecialLocationsItemSource" from plugin.
[Debug 13:10:31.313] [PluginManager] Loaded "ScreenshotItemSource" from plugin.
[Debug 13:10:31.330] [PluginManager] Loaded "ScreenItemSource" from plugin.

(Do:19350): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.

[Info 13:10:31.361] [Services] Successfully located service of type PathsService.
[Debug 13:10:31.362] [PluginManager] Loaded "WindowItemSource" from plugin.
[Debug 13:10:31.367] [PluginManager] Loaded "EmailAction" from plugin.
[Debug 13:10:31.367] [PluginManager] Loaded "OpenAction" from plugin.
[Debug 13:10:31.374] [PluginManager] Loaded "OpenUrlAction" from plugin.
[Debug 13:10:31.374] [PluginManager] Loaded "OpenWithAction" from plugin.
[Debug 13:10:31.374] [PluginManager] Loaded "RevealAction" from plugin.
[Debug 13:10:31.374] [PluginManager] Loaded "RunAction" from plugin.
[Debug 13:10:31.375] [PluginManager] Loaded "OpenSearchAction" from plugin.
[Debug 13:10:31.376] [PluginManager] Loaded "PastebinAction" from plugin.
[Debug 13:10:31.377] [PluginManager] Loaded "GoogleCalculatorAction" from plugin.
[Debug 13:10:31.377] [PluginManager] Loaded "NewNoteAction" fr...

Read more...

Robert Dyer (psybers) wrote :

It looks to me likes its running just fine. In fact if you look at the log it does a reload 2 minutes later, so it definitely ran for 2 minutes!

I think perhaps you dont know how to summon. You have to type the '<super>+space' keys (super is also known as the windows key on many keyboards). This should bring up the Do window.

If you are having troubles summoning (perhaps its bound to another key), you can still verify Do is running by opening a second terminal and running 'gnome-do'. This should summon the window in the original instance and then terminate the new instance!

Changed in do:
status: Incomplete → Invalid
xavs (olivao) wrote :

Shame on me...

As you say gnome-do is running correctly. I was expecting Docky to come up automatically (since I had it configured this way), but Do conf was set to default.

Thanks and sorry for this false alarm...

Tim Borden (timborden) wrote :
Download full text (5.8 KiB)

I'm having the same problem. Here is the output from the --debug flag:

$ gnome-do --debug
WARNING: [Do.Banshee,1.0] Could not load some add-in assemblies: File '/usr/lib/banshee-1/Banshee.CollectionIndexer.dll' not found.
ERROR: Errors found in add-in '/usr/lib/gnome-do/plugins/Banshee.dll:
ERROR: The file '/usr/lib/banshee-1/Banshee.CollectionIndexer.dll' referenced in the manifest could not be found.
[Debug 10:34:31.629] [SystemService] Using org.freedesktop.DeviceKit.Power for battery information
[Info 10:34:31.636] [Services] Successfully located service of type ILogService.
[Info 10:34:31.637] [Services] Successfully located service of type IPreferencesService.
[Info 10:34:31.638] [Services] Successfully located service of type ISecurePreferencesService.
[Info 10:34:31.643] [Services] Successfully located service of type INotificationsService.
[Debug 10:34:31.647] [InterfaceManager] "Glass" interface was loaded
[Info 10:34:31.648] [Services] Successfully located service of type ILogService.
[Debug 10:34:31.648] [InterfaceManager] "Docky" interface was loaded
[Debug 10:34:31.649] [InterfaceManager] "Mini" interface was loaded
[Debug 10:34:31.649] [InterfaceManager] "Classic" interface was loaded
[Debug 10:34:31.650] [InterfaceManager] "Nouveau" interface was loaded
[Info 10:34:31.657] [Services] Successfully located service of type IPreferencesService.
[Info 10:34:31.657] [Services] Successfully located service of type ISecurePreferencesService.
[Info 10:34:31.663] [Services] Successfully located service of type ICoreService.
[Info 10:34:31.666] [Services] Successfully located service of type INetworkService.
[Debug 10:34:31.671] [PluginManager] Loaded "WeatherItemSource" from plugin.
[Info 10:34:31.673] [Services] Successfully located service of type AbstractApplicationService.
[Debug 10:34:31.674] [PluginManager] Loaded "InternalItemSource" from plugin.
[Debug 10:34:31.674] [PluginManager] Loaded "ItemSourceItemSource" from plugin.
[Debug 10:34:31.675] [PluginManager] Loaded "ApplicationItemSource" from plugin.
[Debug 10:34:31.676] [PluginManager] Loaded "GNOMESpecialLocationsItemSource" from plugin.
[Debug 10:34:31.678] [PluginManager] Loaded "MusicItemSource" from plugin.
[Debug 10:34:31.685] [PluginManager] Loaded "ScreenItemSource" from plugin.

(Do:5040): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.

[Info 10:34:31.712] [Services] Successfully located service of type PathsService.
[Debug 10:34:31.713] [PluginManager] Loaded "WindowItemSource" from plugin.
[Debug 10:34:31.714] [PluginManager] Loaded "EmailAction" from plugin.
[Debug 10:34:31.714] [PluginManager] Loaded "OpenAction" from plugin.
[Debug 10:34:31.719] [PluginManager] Loaded "OpenUrlAction" from plugin.
[Debug 10:34:31.719] [PluginManager] Loaded "OpenWithAction" from plugin.
[Debug 10:34:31.719] [PluginManager] Loaded "RevealAction" from plugin.
[Debug 10:34:31.719] [PluginManager] Loaded "RunAction" from plugin.
[Debug 10:34:31.720] [PluginManager] Loaded "DefineAction" from plugin.
[Debug 10:34:31.721] [PluginManager] Loaded "MapAction" from plugin.
[Debug 10:34:31.721] [PluginManager] Loaded "CopyToClipboardAction" from plugin.
[Deb...

Read more...

Tim Borden (timborden) on 2009-12-17
Changed in do:
status: Invalid → Incomplete
Robert Dyer (psybers) on 2009-12-17
Changed in do:
status: Incomplete → Invalid
Robert Dyer (psybers) wrote :

@Tim: this bug is invalid. Please search and see if your specific bug is already reported and if not, report it as a new bug.

Also note that there is 0.8.3.1 released but this is not in the Ubuntu repos. Thus, if you are not running 0.8.3.1 you need to file the bug against the *package* in Ubuntu and not the project itself. If you are indeed running 0.8.3.1 and experiencing problems, please file against the project.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions