Invalid Gconf keys => not stored keybindings

Reported by Szunti on 2009-11-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Do
High
Unassigned

Bug Description

Hi!

GConf key names were internationalized, although they have to be ASCII. I made them use always the original english names.

Related branches

Szunti (szunti) wrote :
Robert Dyer (psybers) wrote :

Thank you for the patch! Although I think you did your diff backwards. ;-)

I'm adding Chris to this bug, he'll get it fixed up.

Changed in do:
assignee: nobody → Chris S. (cszikszoy)
importance: Undecided → Wishlist
status: New → Confirmed
status: Confirmed → Triaged
Szunti (szunti) wrote :

I don't think it is backwards. Made with bzr diff. And applying the patch to the trunk makes the changes I wanted.
(I write so much because it's my first patch, and I am rather uncertain.)

Robert Dyer (psybers) wrote :

Oh I completely misread your bug report. Why would we want to not internationalize them? I think that is *not* what we want!

Changed in do:
status: Triaged → Won't Fix
Robert Dyer (psybers) wrote :

Ohhhhh I see what youre saying now. The gconf key changes if you change your language! Good catch! :-)

I think we want a slightly different fix though, so we'll look into it.

Szunti (szunti) wrote :

The problem is not only that they change with language, I am hungarian and gnome-do want to make/read gconf key named like "Törlés", and gconf report errors that key names have to be ascii, therefore the settings are not stored. I have errors with setting/getting keys. getting/setting means those two case.

Translated error message, sry if I use wrong terms:

 "[Error 19:17:58.699] Encountered error getting/setting GConf key Do/Platform/Common/AbstractKeyBindingService/Törlés: Invalid key or directory name: „/apps/gnome-do/preferences/Do/Platform/Common/AbstractKeyBindingService/Törlés”: „\303” is not ASCII char, therefore can't be used in keynames"

(Original:
"[Error 19:17:58.699] Encountered error getting/setting GConf key Do/Platform/Common/AbstractKeyBindingService/Törlés: Rossz kulcs vagy könyvtárnév: „/apps/gnome-do/preferences/Do/Platform/Common/AbstractKeyBindingService/Törlés”: „\303” nem ASCII karakter, így kulcsnevekben nem használható")

Szunti, I understand the problem and am working on a fix. Thanks for
the report!

On Sat, Nov 7, 2009 at 10:27 AM, Szunti <email address hidden> wrote:
> The problem is not only that they change with language, I am hungarian
> and gnome-do want to make/read gconf key named like "Törlés", and gconf
> report errors that key names have to be ascii, therefore the settings
> are not stored. I have errors with setting/getting keys. getting/setting
> means those two case.
>
>
> Translated error message, sry if I use wrong terms:
>
>  "[Error 19:17:58.699] Encountered error getting/setting GConf key
> Do/Platform/Common/AbstractKeyBindingService/Törlés: Invalid key or
> directory name: „/apps/gnome-
> do/preferences/Do/Platform/Common/AbstractKeyBindingService/Törlés”:
> „\303” is not ASCII char, therefore can't be used in keynames"
>
> (Original:
> "[Error 19:17:58.699] Encountered error getting/setting GConf key Do/Platform/Common/AbstractKeyBindingService/Törlés: Rossz kulcs vagy könyvtárnév: „/apps/gnome-do/preferences/Do/Platform/Common/AbstractKeyBindingService/Törlés”: „\303” nem ASCII karakter, így kulcsnevekben nem használható")
>
> --
> Invalid Gconf keys  => not stored keybindings
> https://bugs.launchpad.net/bugs/474619
> You received this bug notification because you are a member of GNOME Do
> Core Team, which is subscribed to GNOME Do.
>
> Status in GNOME Do: Won't Fix
>
> Bug description:
> Hi!
>
> GConf key names were internationalized, although they have to be ASCII. I made them use always the original english names.
>

Robert Dyer (psybers) wrote :

Szunti, yup we understand. We can't just use your patch (though that is definitely part of the fix!) because then the strings in the dialog wont be internationalized. Chris will get a fix soon though! Thanks for the bug report.

Changed in do:
status: Won't Fix → Triaged
Szunti (szunti) wrote :

Sorry. I wasn't sure. I hope I helped more than annoyed.

Vincent Untz (vuntz) wrote :

Any hope of getting this patch applied?

Chris Halse Rogers (raof) wrote :

Thanks for the ping. Chris obviously hasn't quite got to it :(.

We can't apply exactly that patch, as it will prevent the translation infrastructure picking up the key names as translatable strings, and we display them in the UI.

I've updated the patch to work around this locally; it just needs testing before I commit it.

Changed in do:
status: Triaged → In Progress
assignee: Chris S. (cszikszoy) → nobody
Changed in do:
status: In Progress → Fix Committed
importance: Wishlist → High
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers