Do

gnome-do crashes if banshee plugin is enabled but Banshee is not installed

Bug #396181 reported by Barra on 2009-07-06
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Do
Medium
Unassigned

Bug Description

ok it's stupid bug but is really simple (IMHO) check if banshee is installed.

Robert Dyer (psybers) wrote :

I'm slightly confused... you don't have Banshee installed and expect the Banshee plugin to work? The plugin disabling itself when unable to find Banshee seems like perfectly valid behavior to me.

Changed in do:
importance: Undecided → Low
status: New → Incomplete
Barra (barra78) wrote :

after reinstallation of ubuntu jaunty (and after the death of my old pc) i have installed gnome-do before install banshee. After activating of my classical plugin gnome-do crash. I spent 1 hour before discover which was the problem (ok ok don't tell me nothing)

I think that the plugin should not crash gnome-do!

 status triaged
 importance medium
 assign raof

Yeah, I know what the problem is here. It's that I suck. The addin.xml
explicitly references /usr/lib/banshee-1/Banshee.CollectionIndexer.dll,
rather than the copy we ship.

Incidentally, I'm no longer sure why we ship a copy of
Banshee.CollectionIndexer, anyway :)

Changed in do:
importance: Low → Medium
status: Incomplete → Triaged
summary: - gnome-do don't start whith banshee plugin enabled if banshee isn't
+ gnome-do won't start if banshee plugin is enabled but Banshee is not
installed
summary: - gnome-do won't start if banshee plugin is enabled but Banshee is not
+ gnome-do crashes if banshee plugin is enabled but Banshee is not
installed
Luis Aranguren (pizzaman) wrote :

Same behavior, gnome-do will crash if bashee is not installed but banshee plugin is activated.
monsterxx8:~$ gnome-do
(Do:6821): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.

[Debug 10:47:37.947] Acquiring org.freedesktop.DBus session instance
[Debug 10:47:37.980] Starting org.bansheeproject.CollectionIndexer

Unhandled Exception: System.Exception: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bansheeproject.CollectionIndexer was not provided by any .service files
  at IBusProxy.StartServiceByName (System.String flags, UInt32 ) [0x00000]
  at NDesk.DBus.Bus.StartServiceByName (System.String name, UInt32 flags) [0x00000]
  at NDesk.DBus.Bus.StartServiceByName (System.String name) [0x00000]
  at Banshee.Collection.Indexer.RemoteHelper.IndexerClient.Start () [0x00000]
  at Banshee.Collection.Indexer.RemoteHelper.SimpleIndexerClient.Start () [0x00000]

Temporary solution to be able to run gnome-do again is to deactivate the banshee plugin, but since gnome-do is not functional will have to be done by editing:
~/.local/share/gnome-do/plugins/addin-db-001/config.xml
and change the line that says
    <Addin id="Do.Banshee,1.0" enabled="True" />
to
    <Addin id="Do.Banshee,1.0" enabled="False" />

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers