Do

Third search controller is doing crazy things

Bug #391053 reported by Alex Launi on 2009-06-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Do
Critical
Jason Smith

Bug Description

In trunk, I think since the Actions as items merge (I'll bzr bisect it later) the third search controller has been doing wonky things. When I use an action that has ModifierItemsOptional = true Do is *always* using "third_pane_item[0]" even when the third pane is not exposed. This is causing all of my tweets from Do to be @ someone, and causing the pastebin plugin to fail with an NRE.

When the Action is first pastebin does not bomb but still choses the first modifier available, the difference seems to be that the third pane filter is failing for pastebin when the item is in the first pane, but not microblogging.

Alex Launi (alexlauni) on 2009-06-23
Changed in do:
milestone: none → 0.8.2
importance: Undecided → Critical
description: updated
Alex Launi (alexlauni) on 2009-06-23
Changed in do:
status: New → Confirmed
Jason Smith (jassmith) wrote :

This was obvious. Even though the logic for controlling this is cleaned up, I forgot to hook up the check for third pane visibility. This should now be fixed in bzr.

Changed in do:
assignee: nobody → Jason Smith (jassmith)
status: Confirmed → Fix Committed
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers