Do

Crash when text dragged over docky

Bug #387152 reported by Chris Halse Rogers on 2009-06-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Do
Medium
Unassigned

Bug Description

Do will deterministically crash when text is dragged over it. To reproduce:
a) Set interface to Docky
b) Select some text
c) Drag this text over the dock. Do will now crash, with:
Gdk-ERROR **: The program 'Do' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAtom (invalid Atom parameter)'.
  (Details: serial 11547 error_code 5 request_code 24 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Trace/breakpoint trap

Chris Halse Rogers (raof) wrote :

As a nice, deterministic crasher, I'm marking this as blocking 0.8.2

Changed in do:
importance: Undecided → Medium
milestone: none → 0.8.2
Robert Dyer (psybers) wrote :

Strange enough, I can not reproduce this problem.

I assume you are using the latest bzr rev.

What application are you dragging text from?
Are you dropping it or simply the drag over crashes it?
What part of the dock are you dragging it over?

I don't see this behaviour in 0.8.1.3. It does occur in trunk r1216.
Dragging text anywhere over the dock causes the crash. The application
that the text comes from does not seem to be significant;
Smuxi, Firefox and Empathy all exhibit this.

Jason Smith (jassmith) wrote :

I can't reproduce this either, the fact that its a BadAtom tells me its
somewhere in our X interaction. This means the following information is
needed:

Xorg version
Kernel version
Mesa/Video information

and most importantly

Architecture

On Mon, 2009-06-15 at 03:45 +0000, Chris Halse Rogers wrote:
> As a nice, deterministic crasher, I'm marking this as blocking 0.8.2
>
> ** Changed in: do
> Importance: Undecided => Medium
>
> ** Changed in: do
> Milestone: None => 0.8.2
>

Chris Halse Rogers (raof) wrote :

Eat hot data!

x86-64 architecture.

xorg-server 2:1.6.1.901-2ubuntu1
X.Org X Server 1.6.1.901 (1.6.2 RC 1)

xserver-xorg-video-intel:
  Installed: 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu2

libgl1-mesa-glx:
  Installed: 7.4.1-1ubuntu2

Jason Smith (jassmith) wrote :

hmmm we are using pretty much the exact same stuff. I have a new mesa but other than that...

Jason Smith (jassmith) wrote :

Can you try this patch and give me output?

Chris Halse Rogers (raof) wrote :

Yes. It fixes the crash, and spits "Precrash" "Postcrash" once per drag
operation to stdout :)

Jason Smith (jassmith) on 2009-06-17
Changed in do:
status: New → Fix Committed
Robert Dyer (psybers) on 2009-06-18
tags: added: crash
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments