Gnome-Do is running after restart but docky isn't showing

Reported by Mark Parigger on 2009-04-27
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Do
Medium
Unassigned

Bug Description

I'm running 9.04 64bit on my HP 6710b with compiz and the old 2.4 Intel driver

After a restart Gnome-Do is running like it should, but there is no way I can get docky to show up. With <Super>+Space I can summon the results window, but still, the black bar isn't showing.

Even killing gnome-do and restarting it doesn't help, only after a X-server restart (Strg+Alt+Backspace) all is back to normal like it should.

I have to mention, that compiz is a little bitchy since 9.04... After a restart and log back on window decorations are not showing for a few seconds, which to me seams like an indicator that compiz takes some time to start.

Can you try disabling compiz and using the metacity compositor and seeing if
that works? Your issues are almost certainly graphics driver related.

--
--Alex Launi

Mark Parigger (mark-climber) wrote :

Switching to metacity changed nothing.
gnome-do won't start in docky-mode.

Maybe the compositor is started to late for gnome-do?

Fabrício Godoy (skarllot) wrote :

I'm having almost same behavior, but if I restart gnome-do everything goes well.
I think gnome-do should wait for compositor signal then show itself.

Mark Parigger (mark-climber) wrote :

Although I haven't changed anything, for the last ~10 restarts or so everything worked just fine.

Strange.

Robert Dyer (psybers) on 2009-06-18
Changed in do:
importance: Undecided → Low
Dario Ruellan (druellan) wrote :

I'm also having this problem. Is strange, because it worked fine for a while, but now after a restart docky did not show up (I think it started to happen after the last Ubuntu update of Docky theme).
Please, note that Do actually works. All other themes work just fine, but Docky is not visible until you restart Do.

To solve the problem I unchecked the autorun option on Do and implemented mine using a sleep command, to let the composite start before Do.

PD: perhaps related to: https://bugs.launchpad.net/do/+bug/324332

Robert Dyer (psybers) wrote :

This isn't exactly related to compositing being unavailable. In that case, Do will default back to showing the Classic non-composite theme. The moment compositing shows up it would then switch back to Docky theme.

There is a race condition where something tries to update the dock window before it is displayed, and GTK goes nuts and winds up making the dock window invisible.

I'm still tracking down what causes this, but the good news is restarting usually fixes it right up.

Changed in do:
status: New → Confirmed
importance: Low → Medium
montini (montini) wrote :

I must add that the CPU usage at the moment of bug appearance is nearly 90%. It is normal after the manual kill of gnome-do application and manual application restart. Maybe something to do with the bug https://bugs.launchpad.net/bugs/270437

burkaygenc (burkaygenc) wrote :

I confirm this bug on Ubuntu Jaunty and Mint Gloria. I suspect it to be related to the docklets. Probably weather docklet which requires an internet connection to update itself.

Also I want to add some symptoms to the bug. I use docky in intellihide mode. When this bug shows up, I can still see the dock, but _some_ icons are missing. For example, right now the firefox icon is there on the dock, and the gnome-do icon is also visible. But the rest is dead. Although I can still click on where the icons are supposed to be, and the corresponding application launches, but the icon is not visible. When I type super+enter (I changed it), for a split second I see the "type to begin search" panel, and then it becomes invisible. I can still type blindly and it works.

Moreover, if I resize the dock, some of the icons become visible again. All of the docklets are visible. One more thing: when my battery (laptop) is fully charged, the battery docklet shows a battery with a cross on it and a plug on the cross. When I mouse over it, it says 119.5% !! Image attached.

Robert Dyer (psybers) wrote :

The weather docklet (at least the latest bzr branch, I can't recall if this made it into 0.8.2 or not) checks for internet before trying to update. The bug described here still occurs, and isn't really related to starting up as I can make it happen randomly just restarting Do.

Regarding the battery, thats a separate bug that I've spotted. Has to do with either suspending or adding/removing the AC cord. Hopefully when we rewrite to use the /sys filesystem it will be fixed.

burkaygenc (burkaygenc) wrote :

By the way, you do not have to restart gnome-do to fix this. After changing the gnome-do theme to something else and then back to docky, I get full functionality. Maybe this just restarts gnome-do internally.

@joeross (joeross) wrote :
Download full text (3.8 KiB)

on jaunty here with same experience. only using trash docklet.

debug output below:

joe@Arcanix:~$ gnome-do --debug
[Debug 23:29:45.583] [SystemService] Using org.freedesktop.PowerManager for battery information
[Info 23:29:45.594] [Services] Successfully located service of type ILogService.
[Info 23:29:45.594] [Services] Successfully located service of type IPreferencesService.
[Info 23:29:45.598] [Services] Successfully located service of type ISecurePreferencesService.
[Info 23:29:45.610] [Services] Successfully located service of type INotificationsService.
[Debug 23:29:45.618] [InterfaceManager] "Docky" interface was loaded
[Info 23:29:45.619] [Services] Successfully located service of type ILogService.
[Debug 23:29:45.619] [InterfaceManager] "Mini" interface was loaded
[Debug 23:29:45.620] [InterfaceManager] "Classic" interface was loaded
[Debug 23:29:45.621] [InterfaceManager] "Glass" interface was loaded
[Debug 23:29:45.622] [InterfaceManager] "Nouveau" interface was loaded
[Info 23:29:45.627] [Services] Successfully located service of type AbstractApplicationService.
[Debug 23:29:45.631] [PluginManager] Loaded "InternalItemSource" from plugin.
[Debug 23:29:45.631] [PluginManager] Loaded "ItemSourceItemSource" from plugin.
[Debug 23:29:45.633] [PluginManager] Loaded "ApplicationItemSource" from plugin.
[Debug 23:29:45.633] [PluginManager] Loaded "GNOMESpecialLocationsItemSource" from plugin.
[Debug 23:29:45.635] [PluginManager] Loaded "EmailAction" from plugin.
[Debug 23:29:45.635] [PluginManager] Loaded "OpenAction" from plugin.
[Debug 23:29:45.667] [PluginManager] Loaded "OpenUrlAction" from plugin.
[Debug 23:29:45.668] [PluginManager] Loaded "OpenWithAction" from plugin.
[Debug 23:29:45.668] [PluginManager] Loaded "RevealAction" from plugin.
[Debug 23:29:45.668] [PluginManager] Loaded "RunAction" from plugin.
[Debug 23:29:45.669] [PluginManager] Loaded "CopyToClipboardAction" from plugin.
[Debug 23:29:45.672] [PluginManager] Loaded "InlineGoogleSearch" from plugin.
[Debug 23:29:45.672] [PluginManager] Loaded "ImFeelingLucky" from plugin.
[Info 23:29:45.675] [Services] Successfully located service of type AbstractSystemService.
[Debug 23:29:45.677] [SystemService] No other application instance detected. Continue startup.
[Info 23:29:45.687] [Services] Successfully located service of type IPreferencesService.
[Info 23:29:45.691] [Services] Successfully located service of type ISecurePreferencesService.
[Debug 23:29:45.727] [Controller] Setting theme Docky
[Info 23:29:45.787] [Services] Successfully located service of type PathsService.

(Do:5961): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.

[Info 23:29:45.952] [Services] Successfully located service of type ICoreService.
[Info 23:29:45.960] [Services] Succ...

Read more...

Stas Sușcov (sushkov) wrote :

Any updates?
Still freezing...

Jonathan Lumb (jonolumb) wrote :

I currently get this bug about 3 in four times when starting up my computer. The fourth time I am even more unfortunate and end up with the 90% CPU bug which could prove disastrous if I am not present at the time to kill the CPU-greedy process (https://bugs.launchpad.net/do/+bug/395190).

Basically, Do.exe does not crash but the gnome-do process is not running when this problem occurs. To open a new instance of gnome-do manually, I first have to kill the Do.exe process in task manager and then open gnome-do again. Interestingly, this problem only ever occurs when Gnome-Do is opened on startup.

In .xsession-errors I am seeing the following:
(Do:4543): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.

I have now setup gnome-do to run with the debug flags at startup and see if I can pick up any more error information about this (or other) bugs - hopefully I can report back soon.

I'm also seing this bug. Here's a screenshot of system monitor while Docky is not showing at all. I don't understand how cpu use can be 200% though.

Biji (biji) wrote :

yup.. cpu load got 100% when this issue happened

Robert Dyer (psybers) wrote :

No, the 100% cpu usage is a different bug entirely.

This bug does not incur large cpu usage, and the program runs fine just doesnt display the dock properly.

Robert Dyer (psybers) wrote :

Oh as a side note, I should point out that this bug is FIXED in Docky 2. It existed in Docky 2 for awhile but I fixed it a few days ago. Docky 1 will not be getting a backport.

Biji (biji) wrote :

oke.. how about that (see attachment)
just restarted karmic and login using gdm
i think this is very bad.. coz i'm always using gnome do since intrepid and never have this issue..

Robert Dyer (psybers) wrote :

You arent listening, that is a different bug. You want bug 395190 not this bug.

Biji (biji) wrote :

sorry, i guess 100% cpu may be caused by do plugins. will try to update that too..

Robert Dyer (psybers) wrote :

Docky 1 (the Do theme version of Docky) has reached the end of its maintenance period and is no longer being supported. Docky 2 (the stand-alone application) is a complete rewrite and thus may or may not be affected by this bug.

Please feel free to install Docky 2 (PPA: https://edge.launchpad.net/~docky-core/+archive/ppa or souce: http://do.davebsd.com/wiki/Installing_Docky) and see if your bug still occurs. If it does, please file the bug against lp:docky (not lp:do!).

Changed in do:
status: Confirmed → Won't Fix
Ben (ben2talk) wrote :

Wow, thanks for the update - actually I've been using Docky but forgot to unsubscribe.

Gnome-do still gets a bit sticky at startup, but Docky is sweet now.

Maybe Launchpad should automatically unsubscribe people who don't actively stay subscribed (as with LinuxOutlaws forums 'you will recieve no more notifications if you don't visit this thread')

I'll bet people are finding it simpler to delete the emails than to visit and unsubscribe.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers