Do

can't activate banshee plugin

Bug #343158 reported by Patrick Ulbrich on 2009-03-15
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Banshee
Invalid
Undecided
Unassigned
Do
Undecided
Unassigned
Do Plugins
High
Alex Launi

Bug Description

if i try to activate the banshee plugin
i get the following error:

Installing "Do.Banshee,1.0" addin...
The following add-ins will be installed:
 - Banshee Media Player v1.0
Installing Banshee Media Player v1.0

Assembly not found: Banshee.CollectionIndexer, Version=1.4.0.0, Culture=neutral
WARNING: [Do.Banshee,1.0] Could not load some add-in assemblies: Could not load file or assembly 'Banshee.CollectionIndexer, Version=1.4.0.0, Culture=neutral' or one of its dependencies.

i'm on ubuntu intrepid and run do 0.8.1 and banshee 1.4.3

Nick B. (futurepilot) wrote :

Setting to confirmed as I can also reproduce this bug.

Changed in do:
status: New → Confirmed
Alex Launi (alexlauni) wrote :

Ok, I have tracked this down, it appears to be a bad pkg-config on banshee's end. There's a very simple work around.
run this in a terminal
$ cp /usr/lib/banshee-1/Banshee.CollectionIndexer.dll ~/.local/share/gnome-do/plugins-0.8.1/addins/Do.Banshee.1.0

then restart Do, it should work.

Changed in do:
status: Confirmed → Invalid
Changed in do-plugins:
assignee: nobody → alexlauni
importance: Undecided → High
status: New → Confirmed
skalka (skalka) wrote :

It works, thanks.

Tom Haddon (mthaddon) wrote :

Are there plans to get this fixed in the jaunty packages, or should we all be doing the manual workaround?

Jaunty packages are out, this won't be fixed in Jaunty. Possibly in a PPA
update, but certainly not in the official Ubuntu packages.

--
--Alex Launi

Tom Haddon (mthaddon) wrote :

I think bugfixes can make it into the current stable release, no? Or is this considered too risky in some way?

Chris Halse Rogers (raof) wrote :

On Fri, 2009-05-08 at 23:09 +0000, Tom Haddon wrote:
> I think bugfixes can make it into the current stable release, no? Or is
> this considered too risky in some way?
>
This might be SRU-able, although we'd want to be a bit careful that it
(a) works for people who already have the plugin installed and (b)
doesn't unexpectedly break people's setups.

tags: added: banshee
tags: added: official-plugins
Alex Launi (alexlauni) on 2009-05-17
Changed in banshee:
status: New → Invalid
Changed in do-plugins:
milestone: none → 0.8.2
status: Confirmed → In Progress
Alex Launi (alexlauni) on 2009-05-18
Changed in do-plugins:
status: In Progress → Fix Committed
Alex Launi (alexlauni) on 2009-07-09
Changed in do-plugins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers