Do

Do should never miss/drop/be too slow to receive characters typed just after being summoned

Bug #327420 reported by Jonathan Austin on 2009-02-09
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Do
High
Unassigned

Bug Description

I have a new netbook, (1.2Ghz Via C7m processor) and often when I summon do and immediately start typing my characters 'get lost' - Do doesn't see them...

So
1. Summon Do with shortcut
2. immediately start typing
3. Note that Do only catches the last few characters of what I was typing (or none at all).

I just tried it now and the text went in to this box (going as fast as possible I got 'this is' in here and 'a test' in Do), instead of into the Do window. I am using Docky but it happens with Classic, and I presume other themes too.

This is a shame because it slows me down quite a bit - I have to think ' Do. Pause. Action' rather than 'Do. Action' and in the times when I do the latter by mistake I end up with 'Do. wtf? oh. <backspace>. Action'

The time it takes for Do to show up on this machine would be perfectly fast enough if all of my typed input was there when it showed... eg if it started recording input the moment I summoned it and did the UI stuff in the background while still logging my typing. To be perfectly clear, I don't care if the letters don't show up as I type them, as long as they show up all at once when Do has had the time it needs to show me a pretty command window.

As a test, please select some text in your current window (for example, this
sentence), and see if you can still catch Do off guard. Every time you
summon Do, it captures the currently selected text. I think the problem, is
you don't have any selected text, the machinery we use to capture the
selected text pauses a little too long.

Jonathan Austin (mailforwho) wrote :

Righty.

If I open Gedit, type something, highlight it and summon Do, ALL my typing gets caught, no matter how fast I try - this is great.

BUT

If I highlight your sentence above, or the one I am writing now in a FF Text Box, the same delay happens and my freshly typed characters are lost (if I have your sentence selected) or they end up overwriting the highlighted text in this box.

I've done quite a few repetitions on the above two and it is reliably as described. Do you want me to try a wider range of apps?

Hmm, I still get everything to work, even when the selection resides in Firefox. I will try to nail this down before the next release. Thank you.

Changed in do:
assignee: nobody → djsiegel
importance: Undecided → High
milestone: none → 0.8.1
status: New → Confirmed
Jason Smith (jassmith) wrote :

This is the Window Manager plugin failing hard. I will work on this

Jonathan Austin (mailforwho) wrote :

This lag still happens even with the Window Manager plugin disabled. What's more, at the moment, I seem to be able to make it fail even with things highlighted in Gedit at the moment. I have time to type 'test' before Do opens.

What other information can I get that might help with this?

Alex Launi (alexlauni) wrote :

What interface are you using? This only happens to me with Docky, and not with any of the other interfaces.

Robert Dyer (psybers) wrote :

I'm experiencing it only with Docky on one machine with the world's slowest video card. Works fine in Classic on that machine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers