Do

Docky's UI division is inconsistent and confusing

Bug #324718 reported by Stefan Nuxoll on 2009-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Do
Medium
Jason Smith

Bug Description

The way Docky divides itself into two halves is horribly inconsistent, one half is dedicated to applications, and the other half is dedicated to....applications, and the trash bin. Making a distinction between apps that are docked, and those that aren't makes little sense, since as soon as a non-docked application is closed it fades away from the dock anyways. Furthermore, putting non-docked applications right next to the trash bin without any logical seperation between them provides even more inconsistency.

Apple's dock implementation has similar issues, where documents and minimized windows get jumbled together with the trash bin on the right side of the dock, but it's always clear that the left side is a set of applications.

The two sides are logically different, the left side is applications, the
right side is windows. This is a little bit confusing but this is how things
work in the GNOME world.

--
--Alex Launi

Travis Watkins (amaranth) wrote :

If they're windows they should show as a little window (thumbnail or stock image) with the app icon as an emblem on the bottom right corner. Right now it looks like you have applications on one side and (for some reason) more applications on the other side.

We have discussed this, and the distinction will change in the next release.

Changed in do:
assignee: nobody → jassmith
status: New → Confirmed
Jason Smith (jassmith) on 2009-02-07
Changed in do:
importance: Undecided → Medium
milestone: none → 0.8.1
status: Confirmed → Fix Committed
Alex Launi (alexlauni) on 2009-04-22
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers