Do

Remove need for plugin repository

Bug #324168 reported by Chris Halse Rogers on 2009-02-02
26
Affects Status Importance Assigned to Milestone
Do
Critical
Alex Launi

Bug Description

Having to generate a plugin repository makes our install process more arduous than it needs to be and makes it more difficult for packagers. It would be nice if we did not need to maintain a repository or to copy plugins to a local repository - this would make enabling plugins faster, and also eliminate a whole class of bugs - see bug 324147 for an example. Possibly we need to treat all plugins as _installed_, but not necessarily _enabled_? Would this also allow us to show the plugin's icon in the plugin browser?

I don't believe that Banshee uses a repository. Perhaps we could model after them?

Related branches

lp:~alexlauni/do/no-repo
Merged into lp:do
Jason Smith (community): Approve on 2009-04-22
Changed in do:
importance: Undecided → Low
status: New → Confirmed
Chris Halse Rogers (raof) wrote :

Bumping the priority of this: bug 330025 is a direct consequence of this. Asking people to occasionally delete ~/.local/gnome-do/plugins-* isn't really a solution.

Changed in do:
importance: Low → High
Chris Halse Rogers (raof) wrote :

OK. This should really, really, be fixed, because it means that updates to the gnome-do-plugins package are worthless - the only way an updated plugin can be used is if:
a) If the new plugin has a higher mono.addins version number, and this is not automatic, or
b) If core starts looking for plugins in a different place (plugins-0.8.1.3 versus plugins-0.8.1.2), or
c) If the user deletes ~/.local/share/gnome-do/plugins-*

I should look at it, but it'd be *great* if someone else did it before me!

Changed in do:
importance: High → Critical
Alex Launi (alexlauni) on 2009-03-30
Changed in do:
assignee: nobody → alexlauni
status: Confirmed → In Progress
Alex Launi (alexlauni) wrote :

I need you! come to irc please!

--
--Alex Launi

Chris Halse Rogers (raof) wrote :

I'm quite busy, but I'll see what I can do this evening.

Alex Launi (alexlauni) wrote :

this has been commited to trunk, please test!

Changed in do:
status: In Progress → Confirmed
Alex Launi (alexlauni) on 2009-04-22
Changed in do:
milestone: none → 0.8.2
status: Confirmed → Fix Committed
Chris Halse Rogers (raof) wrote :

Released in 0.8.2

Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers