Do

gnome-do hangs when the system is not already started

Bug #324076 reported by aloctavodia on 2009-02-01
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Do
Low
Unassigned

Bug Description

Do start as part of my gnome session. If i try to run Do when the system is not fully loaded (I can see the wallpaper and the gnome-panel, but the hard drive is still making noise). Do hangs and is impossible to recover from it. i need to kill Do and restart it.
  The workaround is really easy, just be a little more patient and wait until the system is fully loaded.

Hans de Graaff (hans-degraaff) wrote :

I am also seeing this problem. It was much more common with gnome-do 0.6.0.1. I've just seen it happen with gnome-do 0.8.0 as well, although the chance that this happens with 0.8.0 seems to be lower.

Are you asking us to be more patient, or are you suggesting you should be
more patient? You are attempting to use Do before your system is started all
the way, so I assume you mean the latter, because Do is neither patient nor
impatient, it's just trying to start as soon as possible.

Hans de Graaff (hans-degraaff) wrote :

I'm using the autostart feature to start gnome-do from gnome-session, i.e. I have it turned on in the Session Preferences of the Gnome System Preferences.

So I guess I'm asking for the former since I'm not doing anything myself. Probably more interesting is to find out why this is a problem in the first place. Placing a delay on startup may fix the symptoms to some extend, but it seems to me there is an underlying issue that causes gnome-do to hang in this case.

aloctavodia (aloctavodia) wrote :

Sorry for the missundestanding David I´m saying that I (or anyone usidn Do) shoud be more patient,
I upgrade to gnome-do 0.8.0 and it seems that the problem disapear, but it seems that is still there for Hans....

Robert Dyer (psybers) on 2009-06-18
Changed in do:
importance: Undecided → Low
Jan Klesnil (klesnil) wrote :

I'm running karmic and this happens to me quite often on my laptop. The gnome-do version is 0.8.2 .

Jan Klesnil (klesnil) wrote :

Is this duplicate of bug #453379?

Changed in do:
status: New → Fix Released
Hans de Graaff (hans-degraaff) wrote :

Could you indicate where this is fixed specifically? I don't see any commits that seem to be related to this.

aloctavodia (aloctavodia) wrote :

this does not happend with gnome-do version 0.8.3 in karmic or lucid.

Hans de Graaff (hans-degraaff) wrote :

It still happens for me on occasion with gnome-do 0.8.3.1.

Changed in do:
status: Fix Released → Confirmed
Jyri-Petteri Paloposki (zeip) wrote :

This also happens for me, Synaptic shows my gnome-do package as being version 0.8.3.1-dfsg-1ubuntu1, so unless aloctavodia mistyped the version number in which this is supposed to be fixed, it seems that it isn't, at least in all cases.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers