Do

Docky: Scroll on window icon should switch between windows of that app

Bug #319805 reported by Jonathan Austin on 2009-01-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Do
Wishlist
Alex Launi

Bug Description

I would love it if I could switch between multiple windows of the same app by scrolling while hovering over icon for that window on the dock.

yes this is definitely a nice feature !
i'm confirming this

Changed in do:
status: New → Confirmed
Alex Launi (alexlauni) on 2009-02-06
Changed in do:
assignee: nobody → alexlauni
importance: Undecided → Wishlist
milestone: none → 0.8.1
Daniel Schierbeck (dasch) wrote :

Very nice idea!

Jonathan Austin (mailforwho) wrote :

Alex, this is awesome... I love it - Thanks for implementing it...

After using it for a bit, I wonder if perhaps we could add that scrolling on the Gnome-Do icon could scroll through all open windows... I'm quickly finding scrolling on apps the best way to find windows and I reckon that skipping the 'think about which app I want' stage might be nice too...

On Sun, Feb 8, 2009 at 6:21 PM, Who <email address hidden> wrote:

> I wonder if perhaps we could add that
> scrolling on the Gnome-Do icon could scroll through all open windows...

There are already much better solutions to this problem, compiz's scale
plugin is an excellent one, and this is basically the same thing as alt-tab.
I don't think that we'll be implementing this feature unless you can preset
a really rock solid use case that these two great solutions don't already
cover.

--
--Alex Launi

Jonathan Austin (mailforwho) wrote :

You're right that when using Compiz, scale and alt+tab are very good solutions... but...

1. I've tried to make Compiz alt+tab be fast, but it just isn't really - it insists on an animated fading effect that (on this gfx card) just bogs everything down... I might be missing the place to turn it off, but I don't think I am :S
2. Scale gives small previews, especially when you have lots of windows - can you tell between different gnome-terminal windows in scale? Now on a netbook display?

On the other hand, when NOT using CompizOn the other hand, when NOT using Compiz I don't know that there really is a better solution. Composited Metacity (my non-Compiz WM of choice) gives me tiny previews when I use alt+tab and just highlights where on the screen the relevant window is - WITHOUT raising it. It is fast, at least... I don't know that there really is a better solution. Composited Metacity (my non-Compiz WM of choice) gives me tiny previews when I use alt+tab and just highlights where on the screen the relevant window is - WITHOUT raising it. It is fast, at least...

In this situation, cycling through decent sized previews of all my windows would be a new and useful ability. The key thing here is that people without Compiz are commonly avoiding it because they have an older system/shaky 3d support, and so the other more funky graphical solutions aren't very fast, so not very useful. The Do scroll solution is really snappy... At least on a one-app-at-a-time basis...

I would guess that when using XFWM4 (with its compositor) or something lighter, a *box with xcompwhatever (does Docky run with this style of setup?), for example, there aren't many better options for quicly choosing windows (though I haven't really looked well into 'skippy').

So, my argument goes: In a non-compizy environment there isn't a good way to quickly look at all of your open windows - this could be an intuitive and fast one.

Jonathan Austin (mailforwho) wrote :

I noticed today that gnome-panel's window list applet allows scrolling anywhere on the applet to cycle through all windows in the way the previous 3 comments have described (though it doesn't wrap around at the end of the list, which gets pretty annoying)

I mention this because
a) It suggests the people developing Gnome feel that Metacity doesn't solve the problem sufficiently well and so this is worth having.
b) Users ditching their bottom panel in return for Do might find that they miss this functionality.

Jason Smith (jassmith) on 2009-02-15
Changed in do:
status: Confirmed → Fix Committed
Robert Dyer (psybers) on 2009-07-03
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers