Do

Copy/Paste using keyboard in Text Mode doesn't work in 1st pane

Bug #318922 reported by Peng Deng on 2009-01-19
44
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Do
Medium
Jason Smith

Bug Description

GNOME Do 0.8 Beta

Copy/Paste using keyboard shortcut Control+C/Control+V use to work in Text Mode in all panes, but is not functioning in 1st pane currently. All themes are affected.

i confirm this using GNOME Do 0.7.97

Changed in do:
status: New → Confirmed
Ali Servet Donmez (exalted) wrote :

Confirmed for GNOME Do 0.8.0 Release

Peng Deng (d6g) wrote :

To be more precisely, copy/paste doesn't work in the 1st pane, but works in the 2nd pane.

description: updated
hackel (hackel) wrote :

Shift-Ins/Del doesn't work, either.

Morriz (modrama) wrote :

Why is it so hard to accept that ppl want to use their second nature copy paste skills in Do? I have asked for this feature for ages, but somehow I feel that David doesn't understand the concepts of usability (while there are lots of sources on the net to learn from), and instead tries to impose his own autistic and psychologically unsupported view on this issue. If you read David's comment int the duplicate of this bug (https://bugs.launchpad.net/do/+bug/213686/comments/1, and in https://bugs.launchpad.net/do/+bug/264859, and on my blog idiotz dot nl), you will see what I mean.
Again, I am a failure at communication, and no Mono developer, so maybe I should just shut up and be happy with what you guys made, but I can imagine a future where these simple issues are addresses and we can all happily use Do as it is supposed to be used. I am still using Launchy to overcome losting state and missing copy/pasty functionality (heck, I actually only use Do to lauch apps, because I am afraid that if I make a typo somewhere I have to retyp everything again :p.).

Morriz (modrama) wrote :

Heck, I am willing to donate a 100 euro's (hope I dont come across cheap here) to you guys for those 2 features:

- keeping state of first input box
- allow full copy, paste and edit functionality of input text (as in launchy)

And I am asking everybody who's with me to donate a similar amount ;)
So who's with me? And where can we donate?

Copy-paste support was supposed to ship in 0.8, but a last-minute bug got in the way. Also, when I offer alternatives to ctrl-C ctrl-V, I do this because of my "unsupported views on usability", but also in lieu of our support of traditional copy and paste. There are some cases where you wish to apply an action or transformation directly to selected text, and in these cases, using the selected text item is much more natural and enjoyable than performing a finger-dance on your keyboard; however, we realize that users also expect "traditional" copy/paste support, and we do support it -- please don't accuse us of refusing to support it. Your points about retaining first-pane state between summons and advanced text editing belong in either separate bug reports on blueprints.

Morriz, please use the donate menu item (or type "donate" in Do) to donate.

Alex Launi (alexlauni) on 2009-02-27
Changed in do:
assignee: nobody → jassmith
importance: Undecided → Medium
milestone: none → 0.8.1
status: Confirmed → Fix Committed
Morriz (modrama) wrote :

Tnx for the quick reply David, I guess I will have to wait till the x64 deb comes out then. But, what I don't get is, why are you thinking up your own views on usability? I studied psychology (not saying im an expert on usability here) and think your suggestions are not in line with findings in the area. Why try to push ppl into using another keyboard action (yes, your 'selected text' option requires new and different keystrokes), which they will not benefit from in any other context but Do?
Like I said, its better to read up on matters of usability. Then you wouldn't try to come up with your techy solutions that go against ppl's deeply engrained workflows. I am happy to talk to you about it some more, but I feel that it wouldn't hit off unless some basic insights were aquired first (I will try to read up in the mean time, because I wasn't born with this knowledge either).
I will add a new blueprint for 'keeping input state in first pane'...

We only come up with our own "techy solutions that go against ppl's deeply engrained workflows" when we feel that those deeply ingrained habits are fundamentally flawed and can be substantially improved. I am fairly certain that the ^c ^v pattern was not the invention of genius psychologists. I find the suggestion that we should not attempt to explore and promote new user interaction patterns is disturbing, and I think many happy Do users would adamantly disagree with you.

MFeif (matt-feifarek) wrote :

I can confirm that this feature WORKS with the Twitter plugin on 0.8/64bit. Just not in the first pane. It's easy to work around:

summon Do
summon twitter (twit...)
type some text
ctrl-V
type some more text
enter to send

Thanks!

It probably would be more consistent if the same thing could work in general text input mode, too, but for those who are finding this bug looking to paste, this will work in the mean-time.

Morriz (modrama) wrote :

Nice work Jason (and everybody else)!
But you David, I find you to be a stubborn man, reading your top down imposed improvements. I dont argue against improving usability, but that takes historical context and knowledge of how the brain works. Let me give you an analogy: I myself sometimes feel that I could move about much better in a high tech wheel chair (like a souped up iBot), as supposed to just walking. I could try to prove my point to the people around me, but they have every right to keep walking, not only because it's easy to do (as supposed to charging your wheelchair before you need it) , but it has become second nature. There's a lot of examples of wrong choices regarding usability that have stuck, and will never be repaired by replacing them with better options lying around (qwerty anybody?), and that has to do with the last part of my analogy. The wrong choice got adopted too soon, and killed the chances of the better solutions to take over. Thats life, and I advise you to pick your areas for improvement well, if you wish for them to be used.

In the mean time, mostly all of my requests have been honoured, which you probably would have never guessed (but instead opposed):
- copy/paste
- shortcuts
- keeping input state (still soliciting for that one. doh!)

Lazy me is waiting for them 3 to really come alive, so I can kick Launchy (its barely alive, but functioning). I want to increase my offer to $250,- for that to happen. Still cheap perhaps, but who's with me?

Jason Smith (jassmith) wrote :

The bug is closed, mooooving on

Alex Launi (alexlauni) on 2009-04-22
Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers