Do

Restriction to modifier items can be violated when the item have children items

Bug #318285 reported by Peng Deng on 2009-01-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Do
High
Jason Smith

Bug Description

GNOME Do 0.8

When the modifier items are supposed to be limited to show only one or several types of items and some of the items can be expanded to show children items, the expansion can violate the restriction.

E.g, when creating a new event using Google Calendar plugin, the third pane should only show Calendar Item. However calendar items in 3rd pane can currently still be expanded to show event items, therefore the modifier item provided to "Perform" function can possibly be of wrong type.

Alex Launi (alexlauni) on 2009-01-18
Changed in do-plugins:
importance: Undecided → High
status: New → Confirmed
Changed in do:
milestone: none → 0.8
Peng Deng (d6g) on 2009-02-02
description: updated
Alex Launi (alexlauni) wrote :

re-targeting for 0.8.1

Changed in do:
milestone: 0.8 → 0.8.1
Alex Launi (alexlauni) on 2009-05-18
Changed in do:
milestone: 0.8.1 → 0.8.2
Alex Launi (alexlauni) on 2009-05-18
Changed in do:
assignee: nobody → Jason Smith (jassmith)
status: Confirmed → In Progress
Alex Launi (alexlauni) on 2009-05-19
Changed in do:
status: In Progress → Fix Committed
Peng Deng (d6g) wrote :

It seems the issue is not yet fixed as the AcceptChildItem function for ThirdController is using the SupportsItem as "filter" but the item selected on the third pane is always a modifier item so the actual function call should be SupportsModifierItemforItems from the Act.

Currently Do not only still allows the wrong type of modifier item being selected but also in some cases filters the valid modifier item out.

I've pushed a branch trying to fix the issue here: lp:~d6g/do/3rd-controller-filter

Changed in do:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers